Cyberduck Mountain Duck CLI

#11056 reopened defect

SAS token not saved unambiguously with multiple bookmarks

Reported by: muzirian Owned by:
Priority: low Milestone:
Component: azure Version: 7.3.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

I have multiple Azure SAS profile bookmarks. It asks for the password/token every time I switch to another bookmark even if I selected save password.

7.3.1 on osx

Change History (4)

comment:1 Changed on May 22, 2020 at 12:48:40 PM by dkocher

  • Component changed from core to azure
  • Resolution set to worksforme
  • Status changed from new to closed

Can you verify you have enabled Preferences → General → Use Keychain.

comment:2 Changed on May 23, 2020 at 8:26:42 AM by muzirian

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Use keychain is enabled. Looks like it happens when multiple bookmarks are added. If add bookmark, open and save key and add another one, when i go back to the first one to open again, it asks for the password again.

comment:3 Changed on May 24, 2020 at 10:39:53 AM by dkocher

I can confirm that we cannot distinguish between tokens for multiple connections saved to the keychain if the bookmarks use the same hostname.

comment:4 Changed on May 24, 2020 at 6:24:34 PM by dkocher

  • Priority changed from normal to low
  • Summary changed from Azure SAS token not getting saved to SAS token not saved unambiguously with multiple bookmarks
Note: See TracTickets for help on using tickets.
swiss made software