Cyberduck Mountain Duck CLI

#11061 closed defect (fixed)

S3 HTTP profile is sending encrypted data after update to 7.4.0

Reported by: marcv Owned by: dkocher
Priority: normal Milestone: 7.4.1
Component: s3 Version: 7.4.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform:

Description

I just updated to Cyberduck 7.4.0, and I tried to connect to an on-premise S3 storage system (Scality-based) that I used to use for testing. I got an error about a failed directory listing. "Failed to parse XML document with handler class org.jets3t.service.impl.rest.XmlResponsesSaxParser$ListBucketHandler. Please contact your web hosting service provider for assistance."

I looked at the logs on my Scality system and my endpoint was sending a "400 Bad request response back".I was using a non-SSL endpoint for this test, and the S3 HTTP cyberduckprofile downloadable on the Amazon S3 protocol page.

When I sniffed the network, I saw a request come in from my client machine where cyberduck is running, but it was all garbage. That's when i started suspecting that the request was coming in SSL-encrypted, on an endpoint configured to not use SSL.

I tried the same cyberduck, and profile/access credentials on an SSL endpoint, and it worked.

Can you please look into this?

Thanks

Change History (5)

comment:1 Changed on Jun 5, 2020 at 12:09:48 PM by dkocher

  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Jun 5, 2020 at 2:29:46 PM by dkocher

Can be reproduced.

comment:3 Changed on Jun 5, 2020 at 2:41:19 PM by dkocher

Regression from r49171.

comment:4 Changed on Jun 8, 2020 at 12:36:55 PM by yla

  • Resolution set to fixed
  • Status changed from assigned to closed

In r49359.

comment:5 Changed on Jun 15, 2020 at 7:48:37 PM by dkocher

  • Milestone changed from 8.0 to 7.4.1
Note: See TracTickets for help on using tickets.
swiss made software