Cyberduck Mountain Duck CLI

#11062 closed defect (fixed)

Google Cloud Storage -- Bad request (interoperability failure)

Reported by: trenzterra Owned by: dkocher
Priority: normal Milestone: 7.5.0
Component: google-storage Version: Nightly Build
Severity: normal Keywords: google cloud storage
Cc: Architecture: Intel
Platform:

Description

Hi there,

I am using Cyberduck on Windows 10 version 2004.

I recently upgraded Cyberduck from version 7.2.7 to 7.4.1 and noticed that I can no longer upload files to Google Cloud Storage using the Google Cloud Storage OAuth method. The error I am getting is an "interoperability error", as shown in the attached screenshot.

I went back to test verisons 7.4.0, 7.3.1 and 7.3.0 and noted that the issue seems to happen beginning with 7.3.1. On version 7.3.0, I have no issues with uploading files to Google Cloud Storage.

I have made sure to remove credentials and remove all saved settings/ files relating to Cyberduck but I still get the same issue.

Currently, my workaround is to use S3 interoperability mode to upload files to Google Cloud Storage. However, it would be good if the native option could be fixed.

Attachments (1)

Interoperability Failure.png (57.4 KB) - added by trenzterra on May 31, 2020 at 2:12:14 PM.

Download all attachments as: .zip

Change History (10)

Changed on May 31, 2020 at 2:12:14 PM by trenzterra

comment:1 follow-up: Changed on Jun 5, 2020 at 1:53:42 PM by dkocher

We cannot reproduce this. Reviewed test in r49350.

comment:2 Changed on Jun 5, 2020 at 2:06:53 PM by trenzterra

I am still having the same issue. Is there any way to share my logs or something? If it helps, I noticed this only happens when I upload a new file. If I am overwriting an existing file, there is no issue.

comment:3 Changed on Jun 5, 2020 at 2:25:19 PM by dkocher

  • Component changed from core to google-storage
  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned

comment:4 Changed on Jun 17, 2020 at 2:27:48 PM by trenzterra

Hi there,

Just wondering if there would be any way to fix this in the near future? I have downloaded the latest 7.4.1 stable release which does not fix the issue.

I was looking through the repository here: https://trac.cyberduck.io/browser/trunk/googlestorage/src/main/java/ch/cyberduck/core/googlestorage?rev=49350&order=date&desc=1 and noted there were changes made on April 21st which coincided with the period between 7.3.0 and 7.3.1. So I think the bug could have been introduced during this stage. The nightlies for immediately before April 21st is no longer available so I cannot confirm this. However, I downloaded the nightly on April 29th (before the additional amendments made on April 30th) and noted the same issue, so I am guessing the April 21st change introduced this bug.

comment:5 Changed on Jul 10, 2020 at 4:14:16 PM by itspage

I am experiencing the exact same issue here on both the windows and the mac clients.

comment:6 in reply to: ↑ 1 Changed on Jul 14, 2020 at 11:09:29 AM by itspage

Replying to dkocher:

We cannot reproduce this. Reviewed test in r49350.

I have now debugged this issue. As part of the upload request, the parameter "storageClass": "multi_regional" is being sent. This parameter is deprecated and will only work for multi regional buckets. Unless Cyberduck is to add support for setting the storage class in preferences, then I suggest the parameter is removed. This will then use the default storage class of the bucket.

comment:8 Changed on Jul 16, 2020 at 12:32:23 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r49520.

comment:9 Changed on Aug 11, 2020 at 9:07:57 AM by dkocher

  • Milestone changed from 8.0 to 7.5.0
Note: See TracTickets for help on using tickets.
swiss made software