Cyberduck Mountain Duck CLI

#11078 closed defect (worksforme)

MountainDuck S3 - Proxy not being used.

Reported by: t3n0r10.juan Owned by:
Priority: high Milestone:
Component: s3 Version: 4.0
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description

Hi,

I do not think the proxy is being used when connecting to S3 while on work VPN. I keep getting timeout errors even though the aws-cli works fine.

Attachments (1)

mountainduck.log (79.7 KB) - added by t3n0r10.juan on Jun 18, 2020 at 7:03:19 PM.
logs

Download all attachments as: .zip

Change History (3)

Changed on Jun 18, 2020 at 7:03:19 PM by t3n0r10.juan

logs

comment:1 Changed on Jul 28, 2020 at 9:27:18 AM by dkocher

2020-06-18 14:43:29.417977-0400 0x3182543  Default     0xe8866f             64468  0    Mountain Duck: (libcore.dylib) [io.mountainduck:Thread-29 ch.iterate.mountainduck.application.callback.ModalPanelAlertCallback] Display alert for failure BackgroundException{class=class ch.cyberduck.core.exception.ConnectionTimeoutException, file=Path{path='/', type=[directory, volume]}, message='Listing directory / failed.', detail='Connect to s3.amazonaws.com:443 [s3.amazonaws.com/52.216.108.213] failed: Connect timed out.', cause='org.apache.http.conn.ConnectTimeoutException: Connect to s3.amazonaws.com:443 [s3.amazonaws.com/52.216.108.213] failed: Connect timed out'}

comment:2 Changed on Aug 27, 2020 at 11:43:27 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

We cannot reproduce this issue. Check your settings in System Preferences → Network → Proxies.

Note: See TracTickets for help on using tickets.
swiss made software