Cyberduck Mountain Duck CLI

#11086 closed defect (fixed)

Temporary local file deleted after editing in external editor

Reported by: techguy12 Owned by: dkocher
Priority: highest Milestone: 7.7.2
Component: core Version: 7.4.1
Severity: critical Keywords: deleted
Cc: Architecture: Intel
Platform: macOS 10.15

Description

SFTP session opens as expected, files can initially be updated, but then after some time (minutes) the file will be listed as (deleted.) This isn't always the case - sometimes I'll edit and save the file and no notification occurs, but the file isn't actually being saved. Re-"editing" the file produces identical behavior - initially fine but at some point the file is "deleted." At this point the app is unusable.

I'm using Visual Studio Code as my editor.

Change History (18)

comment:1 Changed on Jul 23, 2020 at 4:11:18 AM by hellohello

I am having the same issue, except my text editor is BBEdit. I am using Macbook Pro 16" On Catalina. This issue happened very rarely on old versions of Cyberduck, whereas the latest version is completely unusable. The issue happens every time I use Cyberduck to edit a file. I am having to find alternative software to complete my work. I am using SFTP.

In Cyberduck, I right-click and select edit on a file. The file opens in BBEdit, and roughly 5-10 mins later the filename has random numbers on the end of it, and I can no longer re-upload my file changes.

Last edited on Jul 23, 2020 at 4:12:36 AM by hellohello (previous) (diff)

comment:2 Changed on Oct 10, 2020 at 3:41:53 PM by dkocher

  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Files marked as deleted to Temporary local file deleted after editing in external editor

comment:3 Changed on Oct 10, 2020 at 3:42:34 PM by dkocher

#11174 closed as duplicate.

comment:4 Changed on Oct 10, 2020 at 3:43:00 PM by dkocher

#11057 closed as duplicate.

comment:5 Changed on Oct 10, 2020 at 6:28:27 PM by dkocher

Relates to #7310.

comment:6 Changed on Oct 10, 2020 at 6:32:26 PM by dkocher

#11150 closed as duplicate.

comment:7 Changed on Oct 17, 2020 at 7:45:11 PM by veggie_89

Having this same issue. Seems like it might be triggered by changing directories/opening a file from another directory. I use Brackets as my external editor. Sometimes it will stop saving updates to server, and other times brackets will close the file with no chance to save changes. Just lost a big chuck of work this way. Looks like I'll need to use another FTP until this is resolved. :(

OS: MacOS 10.14.6 Cyberduck: 7.6.2 Editor: Brackets

comment:8 Changed on Nov 2, 2020 at 1:24:43 PM by dkocher

  • Milestone changed from 8.0 to 7.7.0

Milestone renamed

comment:9 Changed on Nov 2, 2020 at 1:24:43 PM by dkocher

  • Milestone changed from 7.7.0 to 8.0.0

Ticket retargeted after milestone closed

comment:10 Changed on Nov 2, 2020 at 1:26:14 PM by dkocher

  • Milestone changed from 8.0.0 to 8.0

Milestone renamed

comment:11 Changed on Nov 5, 2020 at 8:10:44 AM by dkocher

#11217 closed as duplicate.

comment:12 Changed on Nov 19, 2020 at 11:10:26 PM by bigtoe4sho

I am also having the same issue. Catalina 10.15.7 CyberDuck 7.7.1. Glad I found this ticket, I have been losing my mind on this for months here. Like this program, but I have to move on from it. I have no confidence in the program and losing work is just not okay. I'll check back periodically and see if it gets fixed down the road. Who knows maybe I'll find something that works better and never look back. Good luck all!

Version 0, edited on Nov 19, 2020 at 11:10:26 PM by bigtoe4sho (next)

comment:13 Changed on Nov 24, 2020 at 7:46:01 PM by dkocher

  • Milestone changed from 8.0 to 7.8.0

comment:14 Changed on Nov 28, 2020 at 6:06:38 PM by dkocher

  • Milestone changed from 7.8.0 to 8.0

Regression from r48561.

comment:15 Changed on Nov 28, 2020 at 6:07:22 PM by dkocher

  • Milestone changed from 8.0 to 7.8.0
  • Resolution set to fixed
  • Status changed from assigned to closed

In r50199.

comment:16 Changed on Nov 29, 2020 at 10:30:12 AM by dkocher

Can you please try if still see this issue with the current snapshot build by updating from within Cyberduck in Preferences → Update → Automatically check for updates in → Snapshot Builds.

comment:17 Changed on Nov 30, 2020 at 2:25:31 PM by dkocher

  • Milestone changed from 7.8.0 to 7.7.2

Milestone renamed

comment:18 Changed on Dec 4, 2020 at 5:48:12 AM by dinisov

Oh my god I think it is fixed I was developing a neurosis because of this. Almost a year of having to re-open the file and then doing Crtl+Y and saving veeeery quickly, rinse and repeat a thousand times. What a relief!

Note: See TracTickets for help on using tickets.