Cyberduck Mountain Duck CLI

#11185 closed defect (fixed)

Backblaze B2 duplicate does not always work properly

Reported by: sparsile Owned by:
Priority: normal Milestone: 7.7
Component: b2 Version: 7.6.0
Severity: normal Keywords: backblaze duplicate
Cc: Architecture: Intel
Platform: Windows 10

Description (last modified by sparsile)

Select a Backblaze B2 bucket, click right and select "Duplicate". Enter the name of the new bucket. The files will start to be copied. The majority of the time, however, a partial copy will be made and then an error "Cannot create folder <new-bucket-name>. Bucket name is already in use. Please contact your web hosting provider for assistance."

In the log (attached), I see a several list POSTs, a create bucket, and a copy file. It then attempts to post another create bucket command, which returns a HTTP 400, then closes.

When I refresh the window, the new bucket and at least one new folder/file has been copied, but not all.

This doesn't happen all of the time. It could potentially be related to transferring "large" files, but no way to explore that any further. Edit to the "large" files comment. I am about 10% through duplicating a folder with a lot of "small" files (<25MB) and it seems to be working OK. We'll see if it finishes. So I suggest that perhaps the problem is related to transferring larger files (hundreds of MB in size).

Thanks for your assistance.

Attachments (1)

backblaze_b2_duplicate_error_log.txt (11.0 KB) - added by sparsile on Sep 24, 2020 at 9:35:53 PM.
Log of Backblaze B2 Duplicate error

Download all attachments as: .zip

Change History (5)

Changed on Sep 24, 2020 at 9:35:53 PM by sparsile

Log of Backblaze B2 Duplicate error

comment:1 Changed on Sep 24, 2020 at 10:01:24 PM by sparsile

  • Description modified (diff)

comment:2 Changed on Oct 10, 2020 at 6:25:51 PM by dkocher

  • Milestone set to 8.0
  • Resolution set to fixed
  • Status changed from new to closed

In r49931.

comment:3 Changed on Nov 2, 2020 at 1:24:43 PM by dkocher

  • Milestone changed from 8.0 to 7.7.0

Milestone renamed

comment:4 Changed on Nov 2, 2020 at 1:26:44 PM by dkocher

  • Milestone changed from 7.7.0 to 7.7

Milestone renamed

Note: See TracTickets for help on using tickets.