Cyberduck Mountain Duck CLI

#1119 closed defect (fixed)

Cyberduck leaks memory badly while uploading via ftp

Reported by: charrison Owned by: dkocher
Priority: high Milestone: 2.8
Component: core Version: 2.7.3
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

When uploading via FTP (and this is most evident on large files), real memory usage steadily increases at about a megabyte per second. I have tracked Cyberduck using up as much as 944 Megabytes of memory in the process of uploading a file that is over a gigiabyte in size. Stopping the transfer and disconnecting the connection does not release the memory. The only way to free it up is to quit the application and relaunch. This is on build 2930 (version 2.7.3).

Change History (3)

comment:1 Changed on May 8, 2007 at 7:59:32 PM by dkocher

Please verify against the lastest nightly build from http://update.cyberduck.ch/nightly. I can't reproduce this.

comment:2 Changed on May 8, 2007 at 8:13:02 PM by charrison

The latest nightly build does not appear to be affected by this issue. Glad to hear that it was already fixed.

comment:3 Changed on May 8, 2007 at 9:00:14 PM by dkocher

  • Milestone changed from 2.9 to 2.8
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software