Cyberduck Mountain Duck CLI

#11196 closed defect (fixed)

Failure to read attributes on S3 downloads (400 Bad Request on HEAD /DIR/file)

Reported by: paolieri Owned by: dkocher
Priority: high Milestone: 7.7.2
Component: s3 Version: 7.6.2
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: macOS 10.15

Description

Using version 7.6.2 (33520), I am unable to download files from S3 buckets (it worked with previous versions).

I can list the contents of a bucket, but when I try [Action] -> [Download], I get the message:

Failure to read attributes of FILENAME.xml
Bad Request. Request Error. Please contact your web hosting service provider for assistance.

The log shows:

Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HEAD /DIR/FILENAME.xml HTTP/1.1
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Thu, 08 Oct 2020 03:25:13 GMT
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: ...
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: my-bucket.s3.amazonaws.com
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201008T032513Z
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.6.2.33520 (Mac OS X/10.15.7) (x86_64)
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HTTP/1.1 400 Bad Request
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-request-id: ...
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-id-2: ...
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Content-Type: application/xml
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Transfer-Encoding: chunked
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Thu, 08 Oct 2020 03:25:13 GMT
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: close
Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3

For the S3 bucket, I used a standard access policy:

{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Sid": "VisualEditor0",
            "Effect": "Allow",
            "Action": [
                "s3:GetObject",
                "s3:ListBucket"
            ],
            "Resource": [
                "arn:aws:s3:::my-bucket",
                "arn:aws:s3:::my-bucket/*"
            ]
        }
    ]
}

Change History (18)

comment:1 Changed on Oct 8, 2020 at 5:01:45 AM by paolieri

I also noticed the following:

Workarounds:

Last edited on Oct 8, 2020 at 5:17:24 AM by paolieri (previous) (diff)

comment:2 Changed on Oct 8, 2020 at 9:18:28 AM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher

What is the region of the bucket and its exact name and/or Host header sent? Please try to set keep the default hostname in the bookmark as s3.amazonaws.com and set the default path to the bucket name such as /my-bucket.

comment:3 Changed on Oct 8, 2020 at 7:48:27 PM by paolieri

The bucket is in the us-west-2 region (Oregon).

We always used the default hostname s3.amazonaws.com, but

The logs above show the Host header sent:

Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: my-bucket.s3.amazonaws.com

(the bucket name was replaced with my-bucket for privacy reasons)

Last edited on Oct 8, 2020 at 7:49:11 PM by paolieri (previous) (diff)

comment:4 Changed on Oct 9, 2020 at 10:54:46 AM by dkocher

I am unable to reproduce this with a test bucket in us-west-2.

2020-10-09 12:53:29.972438+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HEAD /10-13.jpg HTTP/1.1
2020-10-09 12:53:29.972496+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 10:53:29 GMT
2020-10-09 12:53:29.972554+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
2020-10-09 12:53:29.972641+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: test-us-west-2-cyberduck.s3.dualstack.us-west-2.amazonaws.com
2020-10-09 12:53:29.972701+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201009T105329Z
2020-10-09 12:53:29.972784+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
2020-10-09 12:53:29.973019+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
2020-10-09 12:53:29.973146+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.6.5.33571 (Mac OS X/10.15.6) (x86_64)

comment:5 Changed on Oct 9, 2020 at 10:56:49 AM by dkocher

The reason for this error may be that we fail to determine the region for the bucket and then default to us-east-1. Can you make sure your IAM policy allows to determine the location of the bucket using s3:GetBucketLocation.

comment:6 Changed on Oct 9, 2020 at 10:57:28 AM by dkocher

You should see a request in the transcript where the bucket location is determined similar to

2020-10-09 12:53:29.218576+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] GET /?location HTTP/1.1
2020-10-09 12:53:29.218640+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 10:53:28 GMT
2020-10-09 12:53:29.218689+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
2020-10-09 12:53:29.218733+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: test-us-west-2-cyberduck.s3.dualstack.us-east-1.amazonaws.com
2020-10-09 12:53:29.218773+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201009T105328Z
2020-10-09 12:53:29.218822+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
2020-10-09 12:53:29.219002+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
2020-10-09 12:53:29.219061+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.6.5.33571 (Mac OS X/10.15.6) (x86_64)
2020-10-09 12:53:29.329824+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HTTP/1.1 200 OK
2020-10-09 12:53:29.329924+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-id-2: vu5yD5cynQkSbIW43SkCYj0wQ0Vrp8Jv1wg8d/5kN7ThMAl01fKc44ThzvEvPOtg7iuNgMGjp2s=
2020-10-09 12:53:29.329987+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-request-id: 3WAM2G2YDR4G8YCY
2020-10-09 12:53:29.330058+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 10:53:30 GMT
2020-10-09 12:53:29.330134+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Content-Type: application/xml
2020-10-09 12:53:29.330240+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Transfer-Encoding: chunked
2020-10-09 12:53:29.330298+0200 0x5dd7d4   Info        0x0                  9866   0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3

comment:7 Changed on Oct 9, 2020 at 10:57:46 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:8 Changed on Oct 9, 2020 at 6:21:18 PM by paolieri

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The problem is easily reproducible from my end and it persists even after adding the s3:GetBucketLocation permission. I can provide login information to a test bucket.

The sequence of requests I see in the logs is

2020-10-09 11:16:09.760054-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HEAD /test.txt HTTP/1.1
2020-10-09 11:16:09.760085-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 18:16:09 GMT
2020-10-09 11:16:09.760107-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: ...
2020-10-09 11:16:09.760122-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: cyberduck-x-test.s3.amazonaws.com
2020-10-09 11:16:09.760136-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201009T181609Z
2020-10-09 11:16:09.760229-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
2020-10-09 11:16:09.760247-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
2020-10-09 11:16:09.760265-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.6.2.33520 (Mac OS X/10.15.7) (x86_64)
2020-10-09 11:16:09.842002-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HTTP/1.1 307 Temporary Redirect
2020-10-09 11:16:09.842027-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-bucket-region: us-west-2
2020-10-09 11:16:09.842038-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-request-id: ...
2020-10-09 11:16:09.842050-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-id-2: ...
2020-10-09 11:16:09.842061-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Location: https://cyberduck-x-test.s3-us-west-2.amazonaws.com/test.txt
2020-10-09 11:16:09.842098-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Content-Type: application/xml
2020-10-09 11:16:09.842110-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Transfer-Encoding: chunked
2020-10-09 11:16:09.842121-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 18:16:08 GMT
2020-10-09 11:16:09.842131-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3
2020-10-09 11:16:09.981394-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HEAD /test.txt HTTP/1.1
2020-10-09 11:16:09.981418-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 18:16:09 GMT
2020-10-09 11:16:09.981439-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: ...
2020-10-09 11:16:09.981451-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: cyberduck-x-test.s3.amazonaws.com
2020-10-09 11:16:09.981463-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201009T181609Z
2020-10-09 11:16:09.981504-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
2020-10-09 11:16:09.981517-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
2020-10-09 11:16:09.981530-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.6.2.33520 (Mac OS X/10.15.7) (x86_64)
2020-10-09 11:16:10.092641-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HTTP/1.1 400 Bad Request
2020-10-09 11:16:10.092673-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-request-id: ...
2020-10-09 11:16:10.092687-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-id-2: ...
2020-10-09 11:16:10.092698-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Content-Type: application/xml
2020-10-09 11:16:10.092719-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Transfer-Encoding: chunked
2020-10-09 11:16:10.092730-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Fri, 09 Oct 2020 18:16:09 GMT
2020-10-09 11:16:10.092741-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: close
2020-10-09 11:16:10.092752-0700 0x11a85e   Info        0x0                  36683  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3

comment:9 follow-up: Changed on Nov 19, 2020 at 10:31:42 AM by francoisj

I have also problems when using buckets in eu-west-3 with Version 7.7.0 (33744)

When using the default "S3 HTTPS" profile and using my-bucket.s3.amazonaws.com as server name, I can open a connection to the bucket, list files and upload some but it fails when trying to download any files (even the one I just uploaded) with a "Failure to read attributes". The 400 is due to "us-east-1" used as a region in AWSv4 signature on a HEAD request against the my-bucket.s3.amazonaws.com. All other requests seems good but not this one.

When using a custom profile forcing region to eu-west-3 (and still using my-bucket.s3.amazonaws.com as server name) it works unreliably. i.e. sometimes the created bookmark will work flawlessly but sometimes it will loop on the first request which is a GET to https://s3.amazonaws.com/ but with region "eu-west-3" and s3.amazonaws.com wants eu-east-1 as a region so we have always 400, when in this state it loops forever and it is really difficult to start any other connection. I don't know what I do differently between the creation of a bookmark which work and one which does not work. I think I do exactly the same steps on both cases but I am probably wrong somewhere.

This makes Cyberduck unusable for me.

comment:10 follow-up: Changed on Nov 19, 2020 at 12:34:13 PM by francoisj

As a side note I did not find how to get the cyberduck logs or transcripts. I resorted to mitmproxy to analyse. I think the wiki should explain how to easily get transcripts to ease bug reporting.

Last edited on Nov 19, 2020 at 12:34:51 PM by francoisj (previous) (diff)

comment:11 in reply to: ↑ 10 Changed on Nov 21, 2020 at 9:13:11 PM by dkocher

Replying to francoisj:

As a side note I did not find how to get the cyberduck logs or transcripts. I resorted to mitmproxy to analyse. I think the wiki should explain how to easily get transcripts to ease bug reporting.

Refer to Provide log output.

Last edited on Nov 21, 2020 at 9:13:34 PM by dkocher (previous) (diff)

comment:12 in reply to: ↑ 9 ; follow-up: Changed on Nov 21, 2020 at 9:14:35 PM by dkocher

Replying to francoisj:

I have also problems when using buckets in eu-west-3 with Version 7.7.0 (33744)

When using the default "S3 HTTPS" profile and using my-bucket.s3.amazonaws.com as server name, I can open a connection to the bucket, list files and upload some but it fails when trying to download any files (even the one I just uploaded) with a "Failure to read attributes". The 400 is due to "us-east-1" used as a region in AWSv4 signature on a HEAD request against the my-bucket.s3.amazonaws.com. All other requests seems good but not this one.

When using a custom profile forcing region to eu-west-3 (and still using my-bucket.s3.amazonaws.com as server name) it works unreliably. i.e. sometimes the created bookmark will work flawlessly but sometimes it will loop on the first request which is a GET to https://s3.amazonaws.com/ but with region "eu-west-3" and s3.amazonaws.com wants eu-east-1 as a region so we have always 400, when in this state it loops forever and it is really difficult to start any other connection. I don't know what I do differently between the creation of a bookmark which work and one which does not work. I think I do exactly the same steps on both cases but I am probably wrong somewhere.

This makes Cyberduck unusable for me.

Please try to set the default hostname s3.amazonaws.com and set the bucket you want to connect to in the Default Path setting instead.

comment:13 Changed on Nov 30, 2020 at 5:41:46 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Also make sure the IAM permission allows to query the region of the bucket (s3:GetBucketLocation).

comment:14 Changed on Nov 30, 2020 at 5:42:21 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:15 Changed on Nov 30, 2020 at 5:43:56 PM by dkocher

This is reproducible

2020-11-30 18:43:28.165232+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HEAD /IMG_4542.jpeg HTTP/1.1
2020-11-30 18:43:28.165303+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Mon, 30 Nov 2020 17:43:28 GMT
2020-11-30 18:43:28.165381+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-content-sha256: e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
2020-11-30 18:43:28.165435+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Host: test-eu-west-3-cyberduck.s3.amazonaws.com
2020-11-30 18:43:28.165484+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-date: 20201130T174328Z
2020-11-30 18:43:28.165574+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Authorization: ********
2020-11-30 18:43:28.165641+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: Keep-Alive
2020-11-30 18:43:28.165694+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] User-Agent: Cyberduck/7.7.2.33846 (Mac OS X/10.15.7) (x86_64)
2020-11-30 18:43:28.183388+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] HTTP/1.1 400 Bad Request
2020-11-30 18:43:28.183471+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-request-id: 92CEB083181F824A
2020-11-30 18:43:28.183528+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] x-amz-id-2: nryLGleSwyV+jFyTNEHMQS5etLG0TCyJTGmiPOe6q7owMMOiCEYP718Ztap6iJO4MfvKBR/xsTI=
2020-11-30 18:43:28.183566+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Content-Type: application/xml
2020-11-30 18:43:28.183621+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Date: Mon, 30 Nov 2020 17:43:27 GMT
2020-11-30 18:43:28.183692+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Server: AmazonS3
2020-11-30 18:43:28.183772+0100 0x731ee3   Info        0x0                  24510  0    Cyberduck: (libcore.dylib) [ch.sudo.cyberduck:transcript] Connection: close

comment:16 in reply to: ↑ 12 Changed on Nov 30, 2020 at 8:24:39 PM by dkocher

Replying to dkocher:

Replying to francoisj:

I have also problems when using buckets in eu-west-3 with Version 7.7.0 (33744)

When using the default "S3 HTTPS" profile and using my-bucket.s3.amazonaws.com as server name, I can open a connection to the bucket, list files and upload some but it fails when trying to download any files (even the one I just uploaded) with a "Failure to read attributes". The 400 is due to "us-east-1" used as a region in AWSv4 signature on a HEAD request against the my-bucket.s3.amazonaws.com. All other requests seems good but not this one.

I can confirm this finding.

<Error><Code>AuthorizationHeaderMalformed</Code><Message>The authorization header is malformed; the region 'us-east-1' is wrong; expecting 'eu-west-3'</Message><Region>eu-west-3</Region><RequestId>976585D82B3A2013</RequestId><HostId>CA9d8EJFYNh6J7ewB0mf1Q1WhP29jRFsAt1rCDqympfWlOI6RzIiDFBL3GL2wXiNIWbMF5/KXHA=</HostId></Error>

comment:17 Changed on Dec 1, 2020 at 8:58:00 AM by dkocher

  • Milestone set to 7.7.2

comment:18 Changed on Dec 1, 2020 at 12:37:28 PM by yla

  • Resolution set to fixed
  • Status changed from reopened to closed

In r50217.

Note: See TracTickets for help on using tickets.