Cyberduck Mountain Duck CLI

#11197 closed defect (fixed)

Unable to connect to cn-north-1 (no region known for bucket)

Reported by: dz902 Owned by: dkocher
Priority: normal Milestone: 7.7
Component: s3 Version: 7.6.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Used provided connection profile, was working fine until some newer version broke it, so reverted to older version and got it working again.

Now neither older or latest version could work. Error: "Login failed: access id not found blah blah".

Turned on debug logging and "no region known for bucket" pops up. This is strange as region should already be provided via URL.

Also tried the CLI credentials connection profile hoping that region set in ~/.aws/config can shed some light on this issue but no prevail.

Loves this tool. Please help. Thanks!

Change History (7)

comment:1 Changed on Oct 9, 2020 at 11:12:46 AM by dkocher

  • Component changed from core to s3
  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned

This is possibly a regression caused by a refactor of the region lookup for buckets. Could you provide temporary access credentials to a bucket in cn-north-1 to test this. Unfortunately we are unable to open an account in AWS China.

comment:2 Changed on Oct 9, 2020 at 5:20:49 PM by dz902

When I tried to create AKSK for you I found a way to connect:

  • Select S3 HTTPS instead of China profile
  • Enter <bucket-name>.s3.cn-north-1.amazonaws.com.cn as domain name
  • Connect

However, I could only view the files but not able to download. Strange.

Here for you test, read only:

AKIAYOVLZZHW7MC3XQFI
6aAX3kTjMPApWYyvsECXjTQCPBm2twoHWkeH+U39

s3://test-duck

Last edited on Oct 10, 2020 at 1:27:02 PM by dkocher (previous) (diff)

comment:3 Changed on Oct 10, 2020 at 1:26:39 PM by dkocher

Thanks for the test credentials. I can reproduce and we are working on a fix.

comment:4 Changed on Oct 10, 2020 at 2:11:23 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r49932.

comment:5 Changed on Oct 12, 2020 at 6:48:54 PM by dkocher

#11203 closed as duplicate.

comment:6 Changed on Nov 2, 2020 at 1:24:43 PM by dkocher

  • Milestone changed from 8.0 to 7.7.0

Milestone renamed

comment:7 Changed on Nov 2, 2020 at 1:26:44 PM by dkocher

  • Milestone changed from 7.7.0 to 7.7

Milestone renamed

Note: See TracTickets for help on using tickets.