Cyberduck Mountain Duck CLI

#11212 closed defect (fixed)

Crash opening QuickLook panel

Reported by: hughchev Owned by:
Priority: normal Milestone: 7.7.2
Component: core Version: 7.6.2
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.11

Description

Sorry, I'm not very technical, but Cyberduck keeps crashing when I try to download a file after changing the destination folder. Also, when I hit the space bar for a (Mac) preview pane, it appears as a half-page, and it's impossible to resize the pane by dragging. Neither of these issues happened until 2-3 weeks ago.

Cheers

Hugh

Attachments (1)

Cyberduck crash 5.11.20.rtf (122.0 KB) - added by hughchev on Nov 5, 2020 at 10:53:43 AM.

Download all attachments as: .zip

Change History (9)

comment:1 Changed on Nov 5, 2020 at 8:38:50 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this error. Please attach the crash report.

Changed on Nov 5, 2020 at 10:53:43 AM by hughchev

comment:2 Changed on Nov 5, 2020 at 10:56:27 AM by hughchev

  • Resolution worksforme deleted
  • Status changed from closed to reopened

You asked for the crash report.

The problem seems to be caused by using the preview facility – ie highlighting an item in Cyberduck and hitting the space bar. This used to work flawlessly, but now (a) the preview window is small, (b) it is difficult to increase the size of the preview by dragging the corner – in fact one can do this in many tiny steps rather than one movement, and (c) it always stays on top of all other Cyberduck windows, and cannot be closed. Once the preview pane has been requested, attempting to download what is being previewed always seems to precipitate a crash.

I did so just now, and the crash report is attached (twice by the look of things – sorry!)

Cheers

Hugh

comment:3 Changed on Nov 23, 2020 at 2:00:45 PM by dkocher

Process:               Cyberduck [4864]
Path:                  /Users/USER/Downloads/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               7.6.2 (33520)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [4864]
User ID:               503

Date/Time:             2020-11-05 10:27:42.229 +0000
OS Version:            Mac OS X 10.11.6 (15G18013)
Report Version:        11
Anonymous UUID:        510539A5-D045-17F2-3202-5B949BC5DA4E

Sleep/Wake UUID:       E370EAF8-FA34-4A47-85DD-3B795CDE20EA

Time Awake Since Boot: 170000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x000000010571f008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x10571f008:
    __LINKEDIT             000000010570d000-000000010571f000 [   72K] r--/rwx SM=COW  /Users/USER/Downloads/Cyberduck.app/Contents/PlugIns/Runtime.jre/Contents/Home/lib/libjava.dylib
--> VM_ALLOCATE            000000010571f000-0000000105720000 [    4K] ---/rwx SM=NUL  
    VM_ALLOCATE            0000000105720000-0000000105721000 [    4K] r--/rwx SM=PRV  

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSWindow convertPointToScreen:]: unrecognized selector sent to instance 0x7fb07f1c9db0'
terminating with uncaught exception of type NSException
abort() called

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff90237452 __exceptionPreprocess + 178
1   libobjc.A.dylib                     0x00007fff9e42f73c objc_exception_throw + 48
2   CoreFoundation                      0x00007fff902a118d -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
3   CoreFoundation                      0x00007fff901a74c1 ___forwarding___ + 1009
4   CoreFoundation                      0x00007fff901a7048 _CF_forwarding_prep_0 + 120
5   Cyberduck                           0x0000000105326e82 -[CDOutlineView previewPanel:frameForURL:] + 542
6   Cyberduck                           0x0000000105326f0e -[CDOutlineView previewPanel:sourceFrameOnScreenForPreviewItem:] + 104
7   QuickLookUI                         0x00007fff8fb25da5 -[QLPreviewPanel _currentItemFrame] + 202
8   QuickLookUI                         0x00007fff8fb278cb -[QLPreviewPanel _closeWithEffect:canToggle:force:] + 644
9   libjnidispatch.dylib                0x000000012552ce74 ffi_call_unix64 + 76
10  ???                                 0x00007fff5a8d5498 0x0 + 140734712599704


comment:4 Changed on Nov 23, 2020 at 2:04:42 PM by dkocher

Regression from r49552 with API usage on macOS 10.12+ only.

comment:5 Changed on Nov 24, 2020 at 12:46:57 PM by yla

  • Resolution set to fixed
  • Status changed from reopened to closed

In r50173.

comment:6 Changed on Nov 30, 2020 at 12:57:25 PM by dkocher

  • Milestone set to 7.8.0

comment:7 Changed on Nov 30, 2020 at 12:58:12 PM by dkocher

  • Summary changed from Crash on Download As to Crash opening QuickLook panel

comment:8 Changed on Nov 30, 2020 at 2:25:31 PM by dkocher

  • Milestone changed from 7.8.0 to 7.7.2

Milestone renamed

Note: See TracTickets for help on using tickets.