Cyberduck Mountain Duck CLI

#11220 closed defect (worksforme)

Unable to overwrite existing file

Reported by: scrutinizer Owned by: dkocher
Priority: normal Milestone:
Component: googledrive Version: 7.6.2
Severity: critical Keywords: overwrite, skips, upload, google drive
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by scrutinizer)

The misbehaviour manifests in one of the two scenarios:

  1. When changing file's location by dragging if the destination already contains a file with the identical name an error alert is raised.
  1. When uploading a file with a name identical to the existing one on Google Drive the file being uploaded is skipped (ignored) despite the fact that under the "Uploading" section of Cyberduck's settings the option to show the prompt is checked.

Change History (5)

comment:1 Changed on Oct 29, 2020 at 3:46:58 AM by scrutinizer

  • Description modified (diff)

comment:2 Changed on Oct 29, 2020 at 6:31:51 PM by scrutinizer

  • Description modified (diff)

comment:3 Changed on Nov 5, 2020 at 8:30:30 AM by dkocher

  • Component changed from core to googledrive
  • Owner set to dkocher
  • Summary changed from Cyberduck is unable to overwrite existing files on Google Drive - no result or error. to Unable to overwrite existing file

comment:4 Changed on Nov 5, 2020 at 8:38:01 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue as the prompt is shown here. Unless you reload a file transfer then it depends on the additional setting Always overwrite when reloading.

comment:5 Changed on Nov 7, 2020 at 2:46:26 AM by scrutinizer

I set to "Always overwrite" and it did the hob, however when I set to "Prompt" the next time I uploaded the same file and moved to the same folder there was no prompting. The option to "Always overwrite when reloading" was enabled since the beginning.

Note: See TracTickets for help on using tickets.