Cyberduck Mountain Duck CLI

#11231 closed defect (fixed)

Crash in NSMutableParagraphStyle setParagraphStyle

Reported by: gerryvz Owned by: dkocher
Priority: high Milestone: 7.7.1
Component: core Version: 7.7.0
Severity: critical Keywords: MacOS 11 Big Sur
Cc: Architecture: Intel
Platform: macOS 11

Description (last modified by dkocher)

I have never been able to get any version (including nightly builds) of Cyberduck to load and run using any public beta of MacOS 11 Big Sur, including the latest final release candidate.

The error message I get is below.

rocess:               Cyberduck [94544]
Path:                  /private/var/folders/*/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               7.7.0 (33744)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [94544]
User ID:               501

Date/Time:             2020-11-10 14:09:47.236 -0500
OS Version:            macOS 11.0.1 (20B5022a)
Report Version:        12
Anonymous UUID:        E2C825AF-3E48-E6EF-1FBF-AF314205A3D1


Time Awake Since Boot: 27000 seconds

System Integrity Protection: enabled

Notes:                 Translocated Process

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x00000001062ae008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x1062ae008:
    __LINKEDIT                  10629c000-1062ae000    [   72K] r--/rwx SM=COW  /var/folders/*/Cyberduck.app/Contents/PlugIns/Runtime.jre/Contents/Home/lib/libjava.dylib
--> VM_ALLOCATE                 1062ae000-1062af000    [    4K] ---/rwx SM=NUL  
    VM_ALLOCATE                 1062af000-1062b0000    [    4K] r--/rwx SM=PRV  

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil'
abort() called
terminating with uncaught exception of type NSException

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff204c16af __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007fff201f93c9 objc_exception_throw + 48
2   CoreFoundation                      0x00007fff20575a9a -[__NSCFString characterAtIndex:].cold.1 + 0
3   CoreFoundation                      0x00007fff20573953 -[__NSArrayM insertObject:atIndex:].cold.2 + 0
4   CoreFoundation                      0x00007fff203e7411 -[__NSArrayM insertObject:atIndex:] + 1135
5   UIFoundation                        0x00007fff239e6b4b __defaultTabStops_block_invoke + 161
6   libdispatch.dylib                   0x00007fff201a47c7 _dispatch_client_callout + 8
7   libdispatch.dylib                   0x00007fff201a596b _dispatch_once_callout + 20
8   UIFoundation                        0x00007fff239e6aa8 -[NSParagraphStyle tabStops] + 51
9   UIFoundation                        0x00007fff23a00fb1 -[NSMutableParagraphStyle setParagraphStyle:] + 283
10  libjnidispatch.dylib                0x0000000106651e74 ffi_call_unix64 + 76
11  ???                                 0x00007ffee9b900a8 0x0 + 140732819636392

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff20321462 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff2034f610 pthread_kill + 263
2   libsystem_c.dylib             	0x00007fff202a2720 abort + 120
3   libc++abi.dylib               	0x00007fff20314418 abort_message + 231
4   libc++abi.dylib               	0x00007fff20305a7d demangling_terminate_handler() + 266
5   libobjc.A.dylib               	0x00007fff201fb9b1 _objc_terminate() + 96
6   libc++abi.dylib               	0x00007fff20313847 std::__terminate(void (*)()) + 8
7   libc++abi.dylib               	0x00007fff203137e9 std::terminate() + 41
8   libdispatch.dylib             	0x00007fff201a47db _dispatch_client_callout + 28
9   libdispatch.dylib             	0x00007fff201a596b _dispatch_once_callout + 20
10  com.apple.UIFoundation        	0x00007fff239e6aa8 -[NSParagraphStyle tabStops] + 51
11  com.apple.UIFoundation        	0x00007fff23a00fb1 -[NSMutableParagraphStyle setParagraphStyle:] + 283
12  libjnidispatch.dylib          	0x0000000106651e74 ffi_call_unix64 + 76
13  libjnidispatch.dylib          	0x000000010665143d ffi_call + 1005

Attachments (2)

Cyberduck_crash.rtf (144.0 KB) - added by gerryvz on Nov 10, 2020 at 7:12:36 PM.
RTF file with crash data.
Cyberduck_crash_17-11-2020.rtf (246.4 KB) - added by gerryvz on Nov 17, 2020 at 5:04:50 PM.

Download all attachments as: .zip

Change History (26)

Changed on Nov 10, 2020 at 7:12:36 PM by gerryvz

RTF file with crash data.

comment:1 Changed on Nov 10, 2020 at 7:59:21 PM by dkocher

  • Description modified (diff)
  • Platform changed from Mac OS X 10.11 to macOS 11

comment:2 Changed on Nov 10, 2020 at 8:01:06 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Nov 10, 2020 at 8:01:37 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Nov 14, 2020 at 8:00:38 PM by dkocher

  • Milestone set to 7.7.1

comment:5 Changed on Nov 14, 2020 at 8:01:38 PM by dkocher

#11239 closed as duplicate.

comment:6 Changed on Nov 14, 2020 at 8:01:52 PM by dkocher

Unfortunately we have not yet been able to reproduce the crash.

comment:7 Changed on Nov 15, 2020 at 9:33:37 AM by dkocher

  • Owner set to dkocher
  • Priority changed from normal to high
  • Status changed from new to assigned
  • Summary changed from Immediate Crash upon Loading - MacOS 11 Big Sur to Crash in NSMutableParagraphStyle setParagraphStyle

comment:8 Changed on Nov 15, 2020 at 11:22:13 AM by gerryvz

As FYI, my system is an iMac Retina 5K, 27-inch, purchased new in November 2019, so a relatively recent machine.

3.7 GHz 6-core Intel Core i5, 40GB 2667 MHz DDR4

Thank you for looking into this. It appears another person had a similar crash, and you consolidated the ticket into this one.

comment:9 Changed on Nov 16, 2020 at 5:11:26 PM by dkocher

#11244 closed as duplicate.

comment:10 Changed on Nov 16, 2020 at 6:13:53 PM by 1adam12

So, I grabbed the 7.7.1 build and that *also* crashes on launch under mac os 11.0.1. here's the crashlog for 7.7.1:

Process:               Cyberduck [39777]
Path:                  /private/var/folders/*/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               7.7.1 (33767)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [39777]
User ID:               502

Date/Time:             2020-11-16 13:08:09.546 -0500
OS Version:            macOS 11.0.1 (20B29)
Report Version:        12
Bridge OS Version:     5.0.1 (18P2561)
Anonymous UUID:        EBC421C2-D218-73AC-8D5A-02EEC0059F0F

Sleep/Wake UUID:       943E540A-3E07-4C7B-A553-BA8C24DEB3CE

Time Awake Since Boot: 180000 seconds
Time Since Wake:       1400 seconds

System Integrity Protection: enabled

Notes:                 Translocated Process

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x00000001078fd008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x1078fd008:
    __LINKEDIT                  1078eb000-1078fd000    [   72K] r--/rwx SM=COW  /var/folders/*/Cyberduck.app/Contents/PlugIns/Runtime.jre/Contents/Home/lib/libjava.dylib
--> VM_ALLOCATE                 1078fd000-1078fe000    [    4K] ---/rwx SM=NUL  
    VM_ALLOCATE                 1078fe000-1078ff000    [    4K] r--/rwx SM=PRV  

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil'
abort() called
terminating with uncaught exception of type NSException

Last edited on Nov 16, 2020 at 7:32:07 PM by dkocher (previous) (diff)

comment:11 Changed on Nov 16, 2020 at 6:14:28 PM by 1adam12

So, I grabbed the 7.7.1 build and that *also* crashes on launch under mac os 11.0.1. here's the crashlog for 7.7.1:

Process:               Cyberduck [39777]
Path:                  /private/var/folders/*/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               7.7.1 (33767)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [39777]
User ID:               502

Date/Time:             2020-11-16 13:08:09.546 -0500
OS Version:            macOS 11.0.1 (20B29)
Report Version:        12
Bridge OS Version:     5.0.1 (18P2561)
Anonymous UUID:        EBC421C2-D218-73AC-8D5A-02EEC0059F0F

Sleep/Wake UUID:       943E540A-3E07-4C7B-A553-BA8C24DEB3CE

Time Awake Since Boot: 180000 seconds
Time Since Wake:       1400 seconds

System Integrity Protection: enabled

Notes:                 Translocated Process

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x00000001078fd008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x1078fd008:
    __LINKEDIT                  1078eb000-1078fd000    [   72K] r--/rwx SM=COW  /var/folders/*/Cyberduck.app/Contents/PlugIns/Runtime.jre/Contents/Home/lib/libjava.dylib
--> VM_ALLOCATE                 1078fd000-1078fe000    [    4K] ---/rwx SM=NUL  
    VM_ALLOCATE                 1078fe000-1078ff000    [    4K] r--/rwx SM=PRV  

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil'
abort() called
terminating with uncaught exception of type NSException

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff204ba6af __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007fff201f23c9 objc_exception_throw + 48
2   CoreFoundation                      0x00007fff2056ea9a -[__NSCFString characterAtIndex:].cold.1 + 0
3   CoreFoundation                      0x00007fff2056c953 -[__NSArrayM insertObject:atIndex:].cold.2 + 0
4   CoreFoundation                      0x00007fff203e0411 -[__NSArrayM insertObject:atIndex:] + 1135
5   UIFoundation                        0x00007fff239e5b4b __defaultTabStops_block_invoke + 161
6   libdispatch.dylib                   0x00007fff2019d7c7 _dispatch_client_callout + 8
7   libdispatch.dylib                   0x00007fff2019e96b _dispatch_once_callout + 20
8   UIFoundation                        0x00007fff239e5aa8 -[NSParagraphStyle tabStops] + 51
9   UIFoundation                        0x00007fff239fffb1 -[NSMutableParagraphStyle setParagraphStyle:] + 283
10  libjnidispatch.dylib                0x0000000107cc9e74 ffi_call_unix64 + 76
11  ???                                 0x00007ffee85e02d8 0x0 + 140732796895960

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff2031a462 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff20348610 pthread_kill + 263
2   libsystem_c.dylib             	0x00007fff2029b720 abort + 120
3   libc++abi.dylib               	0x00007fff2030d418 abort_message + 231
4   libc++abi.dylib               	0x00007fff202fea7d demangling_terminate_handler() + 266
5   libobjc.A.dylib               	0x00007fff201f49b1 _objc_terminate() + 96
6   libc++abi.dylib               	0x00007fff2030c847 std::__terminate(void (*)()) + 8
7   libc++abi.dylib               	0x00007fff2030c7e9 std::terminate() + 41
8   libdispatch.dylib             	0x00007fff2019d7db _dispatch_client_callout + 28
9   libdispatch.dylib             	0x00007fff2019e96b _dispatch_once_callout + 20
10  com.apple.UIFoundation        	0x00007fff239e5aa8 -[NSParagraphStyle tabStops] + 51
11  com.apple.UIFoundation        	0x00007fff239fffb1 -[NSMutableParagraphStyle setParagraphStyle:] + 283
12  libjnidispatch.dylib          	0x0000000107cc9e74 ffi_call_unix64 + 76


Last edited on Nov 17, 2020 at 7:38:51 AM by dkocher (previous) (diff)

comment:12 Changed on Nov 16, 2020 at 7:31:34 PM by dkocher

#11245 closed as duplicate.

comment:13 Changed on Nov 17, 2020 at 7:39:01 AM by dkocher

Submitted as FB8902752.

comment:14 Changed on Nov 17, 2020 at 8:04:56 AM by dkocher

#11247 closed as duplicate.

comment:15 Changed on Nov 17, 2020 at 10:21:45 AM by yla

  • Resolution set to fixed
  • Status changed from assigned to closed

In r50133.

comment:16 Changed on Nov 17, 2020 at 11:01:25 AM by dkocher

Can you please try if still see this issue with the current snapshot build 7.7.1.33779.

comment:17 Changed on Nov 17, 2020 at 1:22:02 PM by gerryvz

Hello Sir,

This nightly snapshot build 7.7.1.33779 works just fine, and all is well. Thank you very much. I am glad that other people found the bug and not just me. I have been beta testing Big Sur since the summer time, and had to use an older version of Cyberduck on a Catalina-based Mac all this time to do my Cyberduck work. So it is a big relief to now have it working again on my iMac. Thank you again.

comment:18 follow-up: Changed on Nov 17, 2020 at 1:39:28 PM by 1adam12

that nightly build link for 7.7.1.33779 isn't working for me?

comment:19 in reply to: ↑ 18 Changed on Nov 17, 2020 at 2:46:29 PM by dkocher

Replying to 1adam12:

that nightly build link for 7.7.1.33779 isn't working for me?

The direct link is https://update.cyberduck.io/nightly/Cyberduck-7.7.1.33779.zip

comment:20 Changed on Nov 17, 2020 at 5:07:15 PM by gerryvz

Please note that the Cyberduck 7.7.1.33779 is working on my computer, but immediately crashes when I select Cyberduck-->About Cyberduck from the top menu bar while running the app. This happened all three times I tried it.

The "Update Software" function works fine, and I am able to use Cyberduck for SFTP purposes. It just seems to be this About Cyberduck function that is causing it to crash.

I have uploaded a crash file from this.

Thanks Gerry

comment:21 Changed on Nov 17, 2020 at 5:55:46 PM by 1adam12

I can also confirm that v7.7.1.33779 is working as well for me under mac os 11.0.1 *and* that choosing 'About Cyberduck' causes an immediate crash. Crashlog available here: https://www.dropbox.com/s/0a09rgvp6fpup6z/cycberduck_771_33779_about_crash.txt?dl=0

comment:22 Changed on Nov 17, 2020 at 6:19:21 PM by 1adam12

also, thank you for getting this fixed! much appreciated! i have been meaning to for a while, but also just donated to Cyberduck - thank you for your good work!

comment:23 Changed on Nov 17, 2020 at 6:22:56 PM by gerryvz

I donated a couple of years ago, but I just now donated again with double my original donation, to express additional Thanks !!

comment:24 Changed on Nov 17, 2020 at 7:09:45 PM by dkocher

Thanks for the additional crash report which confirms this is a bug in macOS 11. We have worked around this issue by no longer calling setParagraphStyle.

Process:               Cyberduck [72150]
Path:                  /private/var/folders/*/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               7.7.1 (33779)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [72150]
User ID:               502

Date/Time:             2020-11-17 12:43:21.968 -0500
OS Version:            macOS 11.0.1 (20B29)
Report Version:        12
Bridge OS Version:     5.0.1 (18P2561)
Anonymous UUID:        EBC421C2-D218-73AC-8D5A-02EEC0059F0F

Sleep/Wake UUID:       1B62CC3F-3B83-4C24-B24C-932CE568C7F9

Time Awake Since Boot: 200000 seconds
Time Since Wake:       4400 seconds

System Integrity Protection: enabled

Notes:                 Translocated Process

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x0000000103db8008
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x103db8008:
    __LINKEDIT                  103da6000-103db8000    [   72K] r--/rwx SM=COW  /var/folders/*/Cyberduck.app/Contents/PlugIns/Runtime.jre/Contents/Home/lib/libjava.dylib
--> VM_ALLOCATE                 103db8000-103db9000    [    4K] ---/rwx SM=NUL  
    VM_ALLOCATE                 103db9000-103dba000    [    4K] r--/rwx SM=PRV  

Application Specific Information:
Performing @selector(aboutMenuClicked:) from sender NSMenuItem 0x6000025a0380
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[__NSArrayM insertObject:atIndex:]: object cannot be nil'
abort() called
terminating with uncaught exception of type NSException

Application Specific Backtrace 1:
0   CoreFoundation                      0x00007fff204ba6af __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007fff201f23c9 objc_exception_throw + 48
2   CoreFoundation                      0x00007fff2056ea9a -[__NSCFString characterAtIndex:].cold.1 + 0
3   CoreFoundation                      0x00007fff2056c953 -[__NSArrayM insertObject:atIndex:].cold.2 + 0
4   CoreFoundation                      0x00007fff203e0411 -[__NSArrayM insertObject:atIndex:] + 1135
5   UIFoundation                        0x00007fff239e5b4b __defaultTabStops_block_invoke + 161
6   libdispatch.dylib                   0x00007fff2019d7c7 _dispatch_client_callout + 8
7   libdispatch.dylib                   0x00007fff2019e96b _dispatch_once_callout + 20
8   UIFoundation                        0x00007fff239e6177 -[NSMutableParagraphStyle setTabStops:] + 199
9   UIFoundation                        0x00007fff239ffe47 -[NSRTFReader defaultParagraphStyle] + 75
10  UIFoundation                        0x00007fff239ffd6e -[NSRTFReader _mutableParagraphStyle] + 112
11  UIFoundation                        0x00007fff239f98c3 controlClass + 1757
12  UIFoundation                        0x00007fff239f8e64 -[NSRTFReader attributedString] + 76
13  UIFoundation                        0x00007fff239f4956 _NSReadAttributedStringFromURLOrData + 3213
14  UIFoundation                        0x00007fff23b08fce -[NSAttributedString(NSAttributedStringUIFoundationAdditions) initWithURL:options:documentAttributes:error:] + 228
15  AppKit                              0x00007fff233d4ec5 +[NSSystemInfoPanel updateOptionsWithCredits:] + 400
16  AppKit                              0x00007fff233d4883 +[NSSystemInfoPanel updateOptions:] + 81
17  AppKit                              0x00007fff233d423a -[NSSystemInfoPanel setOptionsDictionary:] + 86
18  AppKit                              0x00007fff233d4095 -[NSApplication(NSStandardAboutPanel) orderFrontStandardAboutPanelWithOptions:] + 56
19  libjnidispatch.dylib                0x0000000111189e74 ffi_call_unix64 + 76
20  ???                                 0x00007ffeed1a64b8 0x0 + 140732876350648

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff2031a462 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff20348610 pthread_kill + 263
2   libsystem_c.dylib             	0x00007fff2029b720 abort + 120
3   libc++abi.dylib               	0x00007fff2030d418 abort_message + 231
4   libc++abi.dylib               	0x00007fff202fea7d demangling_terminate_handler() + 266
5   libobjc.A.dylib               	0x00007fff201f49b1 _objc_terminate() + 96
6   libc++abi.dylib               	0x00007fff2030c847 std::__terminate(void (*)()) + 8
7   libc++abi.dylib               	0x00007fff2030c7e9 std::terminate() + 41
8   libdispatch.dylib             	0x00007fff2019d7db _dispatch_client_callout + 28
9   libdispatch.dylib             	0x00007fff2019e96b _dispatch_once_callout + 20
10  com.apple.UIFoundation        	0x00007fff239e6177 -[NSMutableParagraphStyle setTabStops:] + 199
11  com.apple.UIFoundation        	0x00007fff239ffe47 -[NSRTFReader defaultParagraphStyle] + 75
12  com.apple.UIFoundation        	0x00007fff239ffd6e -[NSRTFReader _mutableParagraphStyle] + 112
13  com.apple.UIFoundation        	0x00007fff239f98c3 controlClass + 1757
14  com.apple.UIFoundation        	0x00007fff239f8e64 -[NSRTFReader attributedString] + 76
15  com.apple.UIFoundation        	0x00007fff239f4956 _NSReadAttributedStringFromURLOrData + 3213
16  com.apple.UIFoundation        	0x00007fff23b08fce -[NSAttributedString(NSAttributedStringUIFoundationAdditions) initWithURL:options:documentAttributes:error:] + 228
17  com.apple.AppKit              	0x00007fff233d4ec5 +[NSSystemInfoPanel updateOptionsWithCredits:] + 400
18  com.apple.AppKit              	0x00007fff233d4883 +[NSSystemInfoPanel updateOptions:] + 81
19  com.apple.AppKit              	0x00007fff233d423a -[NSSystemInfoPanel setOptionsDictionary:] + 86
20  com.apple.AppKit              	0x00007fff233d4095 -[NSApplication(NSStandardAboutPanel) orderFrontStandardAboutPanelWithOptions:] + 56
21  libjnidispatch.dylib          	0x0000000111189e74 ffi_call_unix64 + 76
22  libjnidispatch.dylib          	0x000000011118943d ffi_call + 1005

Note: See TracTickets for help on using tickets.