Cyberduck Mountain Duck CLI

#1128 closed defect (worksforme)

CD launches, but all menus grey, and can't open a new connection.

Reported by: spinkb Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 2.7.3
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

FYI, I am using Java 1.6DP from a couple weeks ago. It may be the root cause. Here is the output in console.log.

ben@…

2007-05-26 16:43:13.567 Cyberduck[22938] Unknown class `ch.cyberduck.ui.cocoa.delegate.HistoryMenuDelegate' in nib file, using `NSObject' instead.
2007-05-26 16:43:13.596 Cyberduck[22938] Unknown class `ch.cyberduck.ui.cocoa.CDMainController' in nib file, using `NSObject' instead.
2007-05-26 16:43:13.691 Cyberduck[22938] Unknown class `ch.cyberduck.ui.cocoa.delegate.EditMenuDelegate' in nib file, using `NSObject' instead.
2007-05-26 16:43:13.691 Cyberduck[22938] Unknown class `ch.cyberduck.ui.cocoa.delegate.BookmarkMenuDelegate' in nib file, using `NSObject' instead.
2007-05-26 16:43:13.691 Cyberduck[22938] Unknown class `ch.cyberduck.ui.cocoa.delegate.RendezvousMenuDelegate' in nib file, using `NSObject' instead.
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action donateMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action licenseMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action preferencesMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action feedbackMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action newDownloadMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action newBrowserMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action newBrowserMenuClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject
2007-05-26 16:43:13.692 Cyberduck[22938] Could not connect the action helpMenuClicked: to target of class NSObject
2007-05-26 16:43:13.693 Cyberduck[22938] Could not connect the action bugreportMenuClicked: to target of class NSObject
2007-05-26 16:43:13.693 Cyberduck[22938] Could not connect the action aboutMenuClicked: to target of class NSObject
2007-05-26 16:43:13.693 Cyberduck[22938] Could not connect the action historyMenuClicked: to target of class NSObject
2007-05-26 16:43:13.693 Cyberduck[22938] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject
2007-05-26 16:43:13.693 Cyberduck[22938] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject

Change History (8)

comment:1 Changed on May 27, 2007 at 10:43:25 AM by dkocher

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Refer to #694. Have you manually changed symlinks in /JavaVM.framework/Versions/?

comment:2 Changed on May 27, 2007 at 11:32:20 AM by spinkb

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Yes. And I know the speel about that being officially unsuportted by Apple. However with the Kernel panics that can be created with ease in Java 1.5 by Apple there was little choice in the matter of going to Java 1.6.

Further, from my testing, changing the preference in the Java pref app is what affects the "launched" java applications. Changing the command line affects apps that are launched via "java -jar" etc. I confirmed this with my own app displaying its current Java version and was surprised to see it was reporting 1.5 until I updated the Java pref application in utilities. The Java launcher in OS X apparently uses it to decide what JVM.

CrushFTP works fine as a Java app, and from command line. Eclipse works fine as well too. Cyberduck is the only Java app not wokring fine.

lrwxr-xr-x 1 root wheel 5 May 6 17:06 1.6 -> 1.6.0 drwxr-xr-x 8 root wheel 272 May 6 17:06 1.6.0 drwxr-xr-x 6 root wheel 204 May 24 21:54 A lrwxr-xr-x 1 root wheel 3 May 6 18:07 Current -> 1.6 lrwxr-xr-x 1 root wheel 3 May 6 18:05 CurrentJDK -> 1.6

Mac Mini Core Duo 10.4.9.

--Ben

comment:3 Changed on May 27, 2007 at 2:06:10 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Adjust the $PATH variable in your bash shell (e.g. by editing ~/.bash_profile) to change the default Java Runtime for applications launched from the command line. Use the Java Preferences.app to change the Java version for applications packaged as a .app.

comment:4 Changed on May 27, 2007 at 3:23:47 PM by spinkb

  • Resolution worksforme deleted
  • Status changed from closed to reopened

That isn't my issue. I want to be using Java 1.6. I have to be to prevent Kernel panics due to bugs in Java 1.5.

Is Java 1.6 supported?

--Ben

comment:5 Changed on May 27, 2007 at 4:37:03 PM by dkocher

Yes, you can choose Java 1.6 in the Java Preferences.app and Cyberduck will run using Java 1.6.

comment:6 Changed on May 27, 2007 at 5:51:04 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:7 Changed on May 27, 2007 at 11:47:47 PM by spinkb

  • Resolution worksforme deleted
  • Status changed from closed to reopened

OK, so what is causing all the menu's to be grayed out and not working?

I wanted to use Cyberduck, but I definitely can't anymore at this point. It used to work just fine in the past.

comment:8 Changed on May 28, 2007 at 11:54:42 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please read the other tickets I referenced. Revert the changes to the symlinks in JavaVM.framework and Cybeduck will work again as advertised.

Note: See TracTickets for help on using tickets.
swiss made software