Cyberduck Mountain Duck CLI

#1149 closed defect (worksforme)

Uploaded files changed to zero length upon completion

Reported by: pentaphobe Owned by: dkocher
Priority: highest Milestone: 2.8
Component: core Version: 2.7.3
Severity: blocker Keywords: upload time out large files
Cc: Architecture:
Platform:

Description

This is a repeatable bug.

(Uploading to a MediaTemple gridserver host (Pure-FTPd))

Larger files complete upload, and then an Operation Timed Out dialog is presented ("cancel" and "try again" buttons) Both buttons result in the file being reduced to zero length.


Notes:

I have confirmed that the file is successfully being uploaded each time, if I ssh in (or connect using another ftp client) while the error dialog is on screen, I can rename the file and it will stay intact.

If I copy the file, I will have the original reduced to zero length, and my copy will be intact (obviously)

Attempted courses of action:

  • made sure that Preferences : Transfers : Uploads : Duplicate Files was set to "Try to resume"
  • unchecked Preferences : Transfers : Permissions : Uploads : Change Permissions (in case a separate thread was timing out and causing the whole operation to be considered failed)
  • Preferences : Advanced : Send NOOP is confirmed on

Actions I have not attempted:

  • Uncheck Preferences : Transfers : Timestamps : Preserve Modification Date

Like I said, this is repeatable - as I've done it for about a dozen uploads, trying different combinations - only had the time to register for ticket submission now.

The first time it happened was after uploading a 900mb archive at 35kb/s on a time-critical project. As much as this was a problem, I'm at least tech savvy enough to have a workaround - but others may not, hence the high priority on this ticket.


This bug only occurs with large files.

I hypothesize that the primary connection thread (browser) may be hitting the 15 minute timeout, and some flag is affecting the transfer threads too.

Since the "send NO OP" option is set, I wouldn't imagine this being the case, but without reviewing source I can only guess.

Change History (3)

comment:1 Changed on Jul 3, 2007 at 6:00:19 AM by dkocher

  • Milestone set to 2.8
  • Status changed from new to assigned

comment:2 Changed on Jul 9, 2007 at 2:46:18 PM by dkocher

Can you replicate the problem in a recent 2.8 build available http://update.cyberduck.ch/nightly/?

comment:3 Changed on Jul 12, 2007 at 9:28:08 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

Cannot replicate this in 2.8.

Note: See TracTickets for help on using tickets.
swiss made software