Cyberduck Mountain Duck CLI

#11547 closed defect (fixed)

Failed multi-part uploads to GCS over S3

Reported by: dbokan Owned by: dkocher
Priority: normal Milestone: 7.8.2
Component: s3 Version: 7.8.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description (last modified by dkocher)

Hi team,

It appears there is a persistent issue with multipart uploads when S3 protocol is used to access Google Cloud Storage. This was detected with version 7.7.2, but still present with update to 7.8.1.

There are some cases where one would prefer this method over actual GCS protocol (i.e. when only authentication method is HMAC), and this did work in older versions like 7.0.1.

I am attaching a screenshot with error log output, but it should be pretty simple to replicate.

Attachments (1)

download.png (56.4 KB) - added by dkocher on Jan 18, 2021 at 10:21:27 AM.

Download all attachments as: .zip

Change History (6)

comment:1 Changed on Jan 17, 2021 at 10:27:58 AM by dkocher

  • Milestone set to 8.0
  • Owner set to dkocher
  • Status changed from new to assigned

Changed on Jan 18, 2021 at 10:21:27 AM by dkocher

comment:2 Changed on Jan 18, 2021 at 10:22:10 AM by dkocher

  • Description modified (diff)

comment:3 Changed on Jan 18, 2021 at 8:13:16 PM by dkocher

Root cause is HTTP/1.1 400 Bad Request with error Invalid argument. POST object expects Content-Type multipart/form-data..

HTTP/1.1 400 Bad Request
X-GUploader-UploadID: ABg5-UwDlntPOW7i23FW4f7a-Syk1tRCJdaNE6ic4ydHdRXVVbyqn01uLoyX8fgJ8YtUOfAlhYxAtfm0M99QXn1g36d556dfuQ
Content-Type: application/xml; charset=UTF-8
Content-Length: 188
Vary: Origin
Date: Mon, 18 Jan 2021 20:12:23 GMT
Server: UploadServer
Alt-Svc: h3-29=":443"; ma=2592000,h3-T051=":443"; ma=2592000,h3-Q050=":443"; ma=2592000,h3-Q046=":443"; ma=2592000,h3-Q043=":443"; ma=2592000,quic=":443"; ma=2592000; v="46,43"

<?xml version='1.0' encoding='UTF-8'?><Error><Code>InvalidArgument</Code><Message>Invalid argument.</Message><Details>POST object expects Content-Type multipart/form-data</Details></Error>

comment:4 Changed on Jan 19, 2021 at 10:57:53 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r50497.

comment:5 Changed on Jan 19, 2021 at 10:57:57 AM by dkocher

  • Milestone changed from 8.0 to 7.8.2
Note: See TracTickets for help on using tickets.