Cyberduck Mountain Duck CLI

#11555 closed defect (fixed)

Oracle Object Storage pre-signed url error

Reported by: hanaw Owned by: dkocher
Priority: normal Milestone: 7.9.1
Component: s3 Version: Nightly Build
Severity: normal Keywords: Oracle pre-signed url
Cc: Architecture: Intel
Platform: macOS 11

Description (last modified by dkocher)

The pre-signed url cannot be accessed via right-click-menu. The respond is

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Message>Either the bucket named 'test' does not exist in the namespace '*BucketNameOfFile*' or you are not authorized to access it. Your namespace is not *BucketNameOfFile*.</Message>
<Code>NoSuchBucket</Code>
</Error>

*BucketNameOfFile* refers the bucket's name where the file located. It seems the generated url consisted my bucket name instead of namespace. This bug shows on both Windows 10 and Macos 11 with version 7.8.2(34160/34161)

Please fix that, thanks.

Attachments (6)

iShot2021-01-24 11.37.58.png (76.7 KB) - added by hanaw on Jan 24, 2021 at 3:39:11 AM.
screen shot of the respond
20210125100009.png (24.1 KB) - added by hanaw on Jan 25, 2021 at 2:01:32 AM.
New secreen shot with version 7.8.2/34164
0.version.png (43.3 KB) - added by hanaw on Jan 27, 2021 at 5:09:26 AM.
1.rightclickmenu.png (131.9 KB) - added by hanaw on Jan 27, 2021 at 5:09:34 AM.
2.certerror.png (91.7 KB) - added by hanaw on Jan 27, 2021 at 5:09:40 AM.
3.errormessage.png (42.5 KB) - added by hanaw on Jan 27, 2021 at 5:09:48 AM.

Download all attachments as: .zip

Change History (16)

Changed on Jan 24, 2021 at 3:39:11 AM by hanaw

screen shot of the respond

comment:1 Changed on Jan 24, 2021 at 9:14:52 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Jan 24, 2021 at 7:10:49 PM by dkocher

  • Milestone set to 7.8.2

Can you please try if still see this issue with the current snapshot build by updating from within Cyberduck in Preferences → Update → Automatically check for updates in → Snapshot Builds. Please install the latest profile from Oracle Cloud Infrastructure which has a new setting to use path-style requests. See also #10956.

comment:3 Changed on Jan 25, 2021 at 2:00:40 AM by hanaw

Thanks for your kindly reply! I've tried to update to the latest version of Cyberduck ( 7.8.2 34164 Windows ) and re-download and import profile above, but the error still exists with the unsecure connection prompt.

This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Message>Either the bucket named 'test' does not exist in the namespace 'img' or you are not authorized to access it. Your namespace is not img.</Message>
<Code>NoSuchBucket</Code>
</Error>

The Screen shot will be attached to the thread.

Just for your info, I've tried S3 Browser, and it seems the url generated in S3 Browser did not contains the bucket name and start with namespace. Thanks!

Changed on Jan 25, 2021 at 2:01:32 AM by hanaw

New secreen shot with version 7.8.2/34164

comment:4 follow-up: Changed on Jan 26, 2021 at 1:36:49 PM by dkocher

  • Milestone 7.8.2 deleted

Can you provide a temporary account for testing and reproducing the issue?

comment:5 Changed on Jan 27, 2021 at 5:08:08 AM by hanaw

The credential and more screenshots has been sent to your mail(dkocher#iterate.ch), Here is some of the reproducing steps: 1.log in with the credential in your email.

  1. choose Bucket named 'testprivatebucket' ,select the test file, and use right click menu to generate a Pre-signed url.
  2. open the link in a brower,then dismiss the cert error.

4.The error message will be shown. Screenshots will be attached to this reply. You may reply my mail for more info.

Changed on Jan 27, 2021 at 5:09:26 AM by hanaw

Changed on Jan 27, 2021 at 5:09:34 AM by hanaw

Changed on Jan 27, 2021 at 5:09:40 AM by hanaw

Changed on Jan 27, 2021 at 5:09:48 AM by hanaw

comment:6 Changed on Jan 27, 2021 at 5:15:53 AM by hanaw

BTW, certification error is just because the url contains the bucket's name, it seems the correct url is

https://<namespace>.compat.objectstorage.ap-tokyo-1.oraclecloud.com/<bucketname>/<filename>.txt?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=<Access Key>/20210127/ap-tokyo-1/s3/aws4_request&X-Amz-Date=20210127T043352Z&X-Amz-Expires=3600&X-Amz-SignedHeaders=host&X-Amz-Signature=<signature>

Since I cannot do any programming, so please test this url by generate corresponding signature.

Last edited on May 10, 2021 at 7:52:38 AM by dkocher (previous) (diff)

comment:7 in reply to: ↑ 4 ; follow-up: Changed on Mar 6, 2021 at 7:10:43 AM by hanaw

Replying to dkocher:

Can you provide a temporary account for testing and reproducing the issue?

Sorry for asking, but is there anything I can help to fix the bug?

comment:8 in reply to: ↑ 7 Changed on May 16, 2021 at 7:59:02 PM by dkocher

Replying to hanaw:

Replying to dkocher:

Can you provide a temporary account for testing and reproducing the issue?

Sorry for asking, but is there anything I can help to fix the bug?

I can reproduce the issue with the provided account.

comment:9 Changed on May 16, 2021 at 8:07:06 PM by dkocher

  • Milestone set to 7.9.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:10 Changed on May 18, 2021 at 8:27:29 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r51284.

Note: See TracTickets for help on using tickets.