Cyberduck Mountain Duck CLI

#1160 closed defect (fixed)

Invalid len argument returned when downloading

Reported by: blind_io Owned by: dkocher
Priority: highest Milestone: 2.8
Component: sftp Version: 2.8b1
Severity: critical Keywords: sftp download error
Cc: blind@… Architecture:
Platform:

Description

When logging on to a server using the SFTP protocol and downloading a file, the following exception is thrown and the download is aborted.

I tried several different servers with the same result. Uploading works fine, and downloading from ordinary FTP servers works without problem.

Exception in thread "Background" java.lang.IllegalArgumentException: invalid len argument
	at ch.ethz.ssh2.sftp.SFTPv3Client.read(Unknown Source)
	at ch.ethz.ssh2.io.SFTPInputStream.read(Unknown Source)
	at ch.cyberduck.core.io.ThrottledInputStream.read(Unknown Source)
	at ch.cyberduck.core.Path.transfer(Unknown Source)
	at ch.cyberduck.core.Path.download(Unknown Source)
	at ch.cyberduck.core.sftp.SFTPPath.download(Unknown Source)
	at ch.cyberduck.core.DownloadTransfer._transferImpl(Unknown Source)
	at ch.cyberduck.core.Transfer.transfer(Unknown Source)
	at ch.cyberduck.core.Transfer.transfer(Unknown Source)
	at ch.cyberduck.core.Transfer.start(Unknown Source)
	at ch.cyberduck.ui.cocoa.CDTransferController$3.run(Unknown Source)
	at ch.cyberduck.ui.cocoa.CDWindowController$1.run(Unknown Source)

Change History (8)

comment:1 Changed on Jul 12, 2007 at 10:19:39 AM by blind_io

  • Keywords download added; upload removed

comment:2 Changed on Jul 12, 2007 at 8:06:19 PM by dkocher

  • Milestone set to 2.8
  • Status changed from new to assigned

comment:3 Changed on Jul 12, 2007 at 9:08:10 PM by dkocher

As a workaround use SCP transfers (Change in Preferences > SFTP). Do you know what SSH software is running on the server?

comment:4 Changed on Jul 12, 2007 at 9:27:54 PM by blind_io

On of the servers is a debian machine. Running sshd -v gives the following result, if it helps.

OpenSSH_3.8.1p1 Debian-8.sarge.6, OpenSSL 0.9.7e 25 Oct 2004

comment:5 Changed on Jul 16, 2007 at 7:58:13 PM by dkocher

  • Summary changed from Unable to download files to Invalid len argument returned when downloading

Would it be possible to get a temporary account on this server?

comment:6 Changed on Jul 17, 2007 at 2:37:00 PM by burneycd

Hi, I'm also having this issue on all the servers I typically connect to (Redhat and CentOS). Some of them are using this:

OpenSSH_4.2p1, OpenSSL 0.9.7f 22 Mar 2005

And others are using this:

sshd version OpenSSH_3.6.1p2

And one is using this:

OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006

The problem happens when trying to download any file.

Couldn't try out the SCP workaround because when I try to open the preferences, the app crashes. :(

(BTW, I know some web hosts who allow SFTP and SSH but specifically disallow SCP connections)

comment:7 Changed on Aug 14, 2007 at 5:47:15 PM by burneycd

Tuesday, August 14, 2007 13:26:10 US/Eastern

214917 [Background] ERROR ch.cyberduck.core.sftp.SFTPPath - SSH channel is closed. (Closing all channels)

I was just trying the new beta. Now that I can set the SCP preference, that works. When I set it back to SFTP, I get the invalid len argument on download and the above is what I see in the console.

So, I removed my preferences and things were working again with SFTP. I tried to compare the good and bad prefs but there's a lot of differences. I did verify that the problem isn't the enterkey.rename pref which I had changed.

If you would like a copy of the good and bad preference files, please email me at pburney@…

So, this issue is no longer valid for me, but I'm not the original poster.

Sincerely,

Paul Burney

comment:8 Changed on Aug 14, 2007 at 9:06:57 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Resolved in r3223.

Note: See TracTickets for help on using tickets.
swiss made software