Cyberduck Mountain Duck CLI

#11641 closed defect (fixed)

Crash with Cannot listen on pipe name error

Reported by: levydev Owned by: svogt
Priority: normal Milestone:
Component: core Version: 7.8.5
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 10

Description

This just started happening. The timing was right after I removed an s3 bucket from AWS that was included in a Cyberduck shortcut

The workaround is that I just ignore the crash dialog and leave it open ( if I click send or dont send report it closes the whole app. If I ignore the dialog and leave it open, I can work in the app without a problem) However this a nuisance despite the workaround. I just upgraded to the latest version to no avail

Attachments (1)

637533850006668064.txt (2.0 KB) - added by levydev on Apr 7, 2021 at 4:02:20 PM.

Download all attachments as: .zip

Change History (7)

comment:1 Changed on Apr 7, 2021 at 6:26:11 AM by svogt

  • Owner set to svogt
  • Status changed from new to assigned

Hi,

Please attach the latest crash report for further investigation. You can reach the crash report

  • on macOS by navigating to ~/Library/Logs/DiagnosticReports - the crash report is named Cyberduc_*.crash.
  • on Windows by navigating to %AppData%\Cyberduck\CrashReporter.

– Sofie

Changed on Apr 7, 2021 at 4:02:20 PM by levydev

comment:2 Changed on Apr 9, 2021 at 8:04:51 AM by dkocher

15	[Exception Info 1]
16	
17	Top-level Exception
18	Type:        System.IO.PipeException
19	Message:     Cannot listen on pipe name 'net.pipe://localhost/iterate/cyberduck.io' because another pipe endpoint is already listening on that name.
20	Source:

comment:3 Changed on Apr 9, 2021 at 8:05:06 AM by dkocher

  • Platform set to Windows 10

comment:4 Changed on Apr 9, 2021 at 8:05:23 AM by dkocher

  • Summary changed from app crashes every time I try to launch to Crash with Cannot listen on pipe name error

comment:5 Changed on Apr 9, 2021 at 8:06:20 AM by dkocher

Can you reproduce the crash after restarting your computer?

comment:6 Changed on Apr 9, 2021 at 11:50:13 AM by levydev

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks. Rebooting the computer fixed the problem.

Note: See TracTickets for help on using tickets.