Cyberduck Mountain Duck CLI

#11678 closed defect (fixed)

DNS resolution failure when reading bucket location

Reported by: demoki2020 Owned by: dkocher
Priority: normal Milestone: 7.9.1
Component: s3 Version: 7.9.0
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by jrlacharnay)

Seit dem Update auf 7.9.0 taucht der Fehler im Anhang auf.

Attachments (2)

cyberduck.PNG (10.3 KB) - added by demoki2020 on May 18, 2021 at 12:23:39 PM.
Screenshot 2021-05-19 182028.png (23.9 KB) - added by jrlacharnay on May 19, 2021 at 4:20:52 PM.

Download all attachments as: .zip

Change History (20)

Changed on May 18, 2021 at 12:23:39 PM by demoki2020

comment:1 Changed on May 19, 2021 at 6:45:11 AM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher
  • Summary changed from S3 Error to DNS resolution failure when reading bucket location

comment:2 Changed on May 19, 2021 at 6:45:44 AM by dkocher

Please provide the log output.

Last edited on May 20, 2021 at 7:19:51 PM by dkocher (previous) (diff)

comment:3 Changed on May 19, 2021 at 4:18:17 PM by jrlacharnay

Hi,

I have exactly the same problem, since version 7.9.0.

I'm connecting to a self-hosted Scality Ring with S3. The problem happens only when I set the bucket name in the "Path" field of the bookmark panel.

Jean-Rémy

Changed on May 19, 2021 at 4:20:52 PM by jrlacharnay

comment:4 follow-up: Changed on May 19, 2021 at 4:23:48 PM by jrlacharnay

On the above screenshot, what I greyed out is the name Cyberduck trying to resolve, which is: <bucket name (default Path)>.<server name>

I think that's the root cause of the problem. In my case I can connect to <server name> but not to <bucket>.<server name>

comment:5 Changed on May 19, 2021 at 4:28:30 PM by jrlacharnay

Note: the last line of my %APPDATA%\cyberduck\cyberduck.log is from 2021-04-22.

comment:6 Changed on May 20, 2021 at 6:26:42 AM by dkocher

  • Milestone set to 7.9.1
  • Status changed from new to assigned

comment:7 in reply to: ↑ 4 ; follow-ups: Changed on May 20, 2021 at 7:20:17 PM by dkocher

Replying to jrlacharnay:

On the above screenshot, what I greyed out is the name Cyberduck trying to resolve, which is: <bucket name (default Path)>.<server name>

I think that's the root cause of the problem. In my case I can connect to <server name> but not to <bucket>.<server name>

I cannot reproduce the problem testing against a Scality S3 installation. Please provide the log output.

comment:8 in reply to: ↑ 7 Changed on May 26, 2021 at 3:03:26 PM by jrlacharnay

  • Description modified (diff)

Replying to dkocher:

Replying to jrlacharnay:

On the above screenshot, what I greyed out is the name Cyberduck trying to resolve, which is: <bucket name (default Path)>.<server name>

I think that's the root cause of the problem. In my case I can connect to <server name> but not to <bucket>.<server name>

I cannot reproduce the problem testing against a Scality S3 installation. Please provide the log output.

comment:9 Changed on May 26, 2021 at 3:05:48 PM by jrlacharnay

  • Description modified (diff)

comment:10 in reply to: ↑ 7 Changed on May 26, 2021 at 3:06:49 PM by jrlacharnay

Replying to dkocher:

I cannot reproduce the problem testing against a Scality S3 installation. Please provide the log output.

Like I said above, my %appdata%\Cyberduck\cyberduck.log seems to not be updated anymore (last updated on 2021-04-22). Is there any setting to activate, or has the log file moved to a new location?

I even created a %appdata%\Cyberduck\default.properties with "logging=debug" in it, no change.

comment:11 follow-up: Changed on May 26, 2021 at 7:22:51 PM by dkocher

Can you please try if still see this issue with the current snapshot build by updating from within Cyberduck in Preferences → Update → Automatically check for updates in → Snapshot Builds.

comment:12 in reply to: ↑ 11 Changed on May 26, 2021 at 8:59:41 PM by jrlacharnay

Yes, same issue with version 7.9.1 (34964). And still no logs.

comment:13 Changed on May 27, 2021 at 6:13:32 AM by lvogt

The debug log works on my side without any issues (version 7.9.1 (34966)).

comment:14 Changed on May 27, 2021 at 7:12:14 AM by dkocher

As a workaround please connect using the S3 (Deprecated path style requests) profile.

comment:15 Changed on May 27, 2021 at 7:18:40 AM by dkocher

Relates to #10888 with fix in r48333.

comment:16 Changed on May 27, 2021 at 7:19:19 AM by dkocher

Duplicate for #10956.

comment:17 Changed on May 27, 2021 at 8:45:56 AM by jrlacharnay

Thanks, the workaround works perfectly!

comment:18 Changed on May 27, 2021 at 8:57:52 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r51335.

Note: See TracTickets for help on using tickets.