Cyberduck Mountain Duck CLI

#11679 closed defect (fixed)

Tranfer extremely slow when using "compare" option

Reported by: dsw Owned by: dkocher
Priority: normal Milestone: 7.9.1
Component: ftp-tls Version: 7.9.0
Severity: normal Keywords: compare, transfer, slow
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

I want to tranfer files from a remote storage unit to a local HD using the "compare" option. Up to the previous version of Cyberduck it worked fine and fast. Now, "comparison" (preparation) is extremely slow: some folders/files that have NOT been changed, and that are thus identical both on my local HD and on the remote storage unit, are "compared/prepared" very slowly. The "comparion slowness" does not seem to be related to the size of the files/folders examined. The problem is reproduclble: after a first slow comparison/transfer, a second comparison/transfer is again slow on some folders (probably the same folders) and no transfer is done as expected. The problem is not encountered when the option "ignore" is used: name checking is made within a few seconds, whereas "comparison" requires about 10 minutes for the same set of files and folders. Is there a problem upon checking of size, modification date, or checksum? NB: The complete set of files/folders to be examined is 85GB, and was about the same when I was using the previous version of Cyberduck about 10 days ago.

Change History (4)

comment:1 Changed on May 18, 2021 at 5:23:25 PM by dkocher

  • Milestone set to 7.9.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 follow-up: Changed on May 18, 2021 at 5:23:59 PM by dkocher

Relates to #11676.

comment:3 in reply to: ↑ 2 Changed on May 18, 2021 at 6:39:35 PM by dsw

Replying to dkocher:

Relates to #11676.

I read ticket #11676 and I reinstalled version 7.8.5: transfer with "compare" option works again fine and fast.

Last edited on May 19, 2021 at 6:46:33 AM by dkocher (previous) (diff)

comment:4 Changed on May 26, 2021 at 8:45:46 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r51329.

Note: See TracTickets for help on using tickets.