Cyberduck Mountain Duck CLI

#118 closed defect (fixed)

SFTP anonymous login by default!

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 2.5.4
Component: sftp Version: 2.5.3
Severity: major Keywords: anonymous speculative background
Cc: trac.cyberduck.ch@… Architecture:
Platform:

Description

I was very surprised when running Cyberduck for the first time that it appeared to attempt an anonymous login spontaneously before asking me for login information.

Seemed like bad news as soon as I saw this unprompted behaviour, before I ran into problems with it. Why it's doing this I don't know, and I can't turn it off.

However, given the configuration of my hosting provider, which checks for multiple usernames attempted during a single SFTP SSH session, this effectively prevents me from using SFTP.

This is the error returned by the server.

IO Error: Change of username or service not allowed: (anonymous,ssh-connection) -> (user@…,ssh-connection)

Can I turn this behaviour off?

Could I suggest an anonymous checkbox in the login window which the user would deliberately choose, instead of a speculative anonymous login in the background first - otherwise this seems very odd behaviour to me.

Change History (3)

comment:1 Changed on Jan 14, 2006 at 4:51:10 PM by dkocher

I cannot reproduce this; is this using the quick connect field?

comment:2 Changed on Jan 14, 2006 at 7:42:16 PM by trac.cyberduck.ch@…

This is straight out of the box, using the SFTP connect option. At one time I removed the default login username, leaving it blank. Maybe linked to this?

comment:3 Changed on Jan 14, 2006 at 8:21:18 PM by dkocher

  • Milestone changed from 2.6 to 2.5.4
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software