Cyberduck Mountain Duck CLI

#1196 closed defect (wontfix)

Connection closed due to timeout while transferring extremely long files

Reported by: mjs Owned by: dkocher
Priority: normal Milestone:
Component: sftp Version: 2.8b1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

There is a problem with transferring extremely long files (multiple gigabytes in size) that the connection gets closed during the transfer. My assumption is that there is a timeout on the server side that closes the whole connection when no command (is there a separate command channel?) gets sent for a given time. It's not the problem of the current file position because the transferred size is always less than 2GB (so it's not a 32 bit number limitation).

Change History (3)

comment:1 Changed on Jul 31, 2007 at 8:19:27 AM by dkocher

Have you tried the setting in Preferences > Connection > Send no operation to keep connection alive?

comment:2 Changed on Jul 31, 2007 at 2:58:46 PM by mjs

Yes I tried this setting (I tested it with both being set/cleared).

comment:3 Changed on Jul 21, 2008 at 5:01:18 PM by dkocher

  • Resolution set to wontfix
  • Status changed from new to closed

You might want to try a SCP transfer or find out what setting is causing the server to close the connection. (There is no seperate command connection for SSH).

Note: See TracTickets for help on using tickets.
swiss made software