Cyberduck Mountain Duck CLI

#1209 closed defect (duplicate)

All files report "Transfer incomplete"

Reported by: mkstevo Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 2.8b1
Severity: minor Keywords:
Cc: Architecture:
Platform:

Description

Transferring files always gives an error once the file has finished . The transfers window reports "Transfer incomplete" .

I think the reason this seems to appear is that the file sizes of the original and the 'remote' file differ .

For example , uploading a simple redirect index page to point people to my new index ( from index.htm to index.html , for anyone who has bookmarked the original page ) I get the report :

index.htm Transfer incomplete 246B of 235B

or:

gCal.htm Transfer incomplete 402B of 391B

The uploaded files all appear to work correctly , and even after uploading 60Mb of an entire site all files seem present and correct .

In case it makes any difference , I am uploading to my dsl webspace , hosted by Pipex

( ftp://[myusername]@dslftp.dsl.pipex.com:21 )

Attachments (1)

error.jpg (78.4 KB) - added by anonymous on Oct 28, 2008 at 7:52:37 AM.

Download all attachments as: .zip

Change History (5)

comment:1 Changed on Aug 10, 2007 at 6:57:05 AM by dkocher

This may be a duplicate of #1025. Do you use ASCII or Auto transfer type?

comment:2 Changed on Aug 10, 2007 at 6:38:34 PM by mkstevo

I have Transfers set to Auto ,

Line endings to Unix ,

Transfer in Ascii mode .*\.txt|.*\.cgi|.*\.htm|.*\.html|.*\.shtml|.*\.xml|.*\.xsl|.*\.php|.*\.php3|.*\.js|.*\.css|.*\.asp|.*\.java|.*\.c|.*\.cp|.*\.cpp|.*\.m|.*\.h|.*\.pl|.*\.py|.*\.rb|.*\.sh

Default connect mode Active .

I may be wrong , but I assume they are the default settings ? Perhaps it is the Line endings conversion which is altering the file size ?

comment:3 Changed on Aug 10, 2007 at 6:50:42 PM by mkstevo

I have just tried various settings ( Unix , Mac , Windows line endings , Auto / Ascii transfer etc. ) on the one file , all transfers report the same 'Transfer incomplete' error , with the same two mismatched file sises being reported every time .

index.htm Transfer incomplete 246B of 235B

comment:4 Changed on Aug 10, 2007 at 7:46:44 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

I reopened #1025 for this. The transferred file size changes when converting line endings.

Changed on Oct 28, 2008 at 7:52:37 AM by anonymous

Note: See TracTickets for help on using tickets.
swiss made software