Cyberduck Mountain Duck CLI

#1223 closed defect (duplicate)

New bookmarks don't seem to work

Reported by: alexanderklar Owned by: dkocher
Priority: high Milestone: 2.8.1
Component: ftp Version: 2.7.3
Severity: major Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Newly added bookmarks don't seem to work. After three trials this message occurs:

I/O Fehler: Verbindung fehlgeschlagen ftp://**********:21 Unexpected null reply received

And here is the log:

220 **.***.***.** FTP server ready
USER *******
331 Password required for ********.
PASS ********
530 Login incorrect.
USER *******
331 Password required for *******.
PASS ********
530 Login incorrect.
USER *******
331 Password required for *******.
PASS ********
530 Login incorrect.
USER *******

The message „Login incorrect.“ is not true. Username and password are right. They work with other FTP software.

This error occurs on a friend's Mac as well and with different FTP servers. Old bookmarks still work, though.

Change History (6)

comment:1 Changed on Aug 21, 2007 at 6:21:24 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)

comment:2 Changed on Aug 21, 2007 at 6:36:57 PM by dkocher

It is very unlikely this has anything to do with adding a new bookmark. The password is stored in the Keychain.

comment:3 Changed on Sep 8, 2007 at 11:31:22 AM by floplus

I can approve this behaviour. I just updated to 2.8b (3212) and added a bookmark. When I tried to connect I got the "password required for..." message only once (because I have a retry setting of 1, probably) and the same error message. When I restarted Cyberduck the same bookmark works.

comment:4 Changed on Oct 3, 2007 at 11:04:27 AM by alexanderklar

The problem persists on my system. After importing my keychain into 1Passwd I deleted them in my login keychain. Now none of my old bookmarks work anymore. It seems that Cyberduck cannot write to the keychain anymore, but I cannot login to any FTP server even when I uncheck „Add to Keychain“ when asked for the password.

comment:5 Changed on Oct 18, 2007 at 11:08:52 AM by dkocher

  • Milestone set to 2.8.1
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #1231.

Note: See TracTickets for help on using tickets.