Cyberduck Mountain Duck CLI

#1227 closed defect (duplicate)

multi-select bug with expanded folders

Reported by: datapharmer Owned by: dkocher
Priority: normal Milestone: 2.8.2
Component: interface Version: 2.8b1
Severity: normal Keywords: download multi-select folder
Cc: Architecture:
Platform:

Description

When multiple items are selected, unselecting an expanded folder does not unselect its contents. If a folder is unselected either the contents of the folder should no longer be selected or there should be a prompt. This is a major issue when downloading content from FTP as it could result in literally Gigabytes of data being downloaded by accident!

Change History (5)

comment:1 Changed on Aug 26, 2007 at 8:20:28 PM by dkocher

  • Resolution set to wontfix
  • Status changed from new to closed

This is expected behavior. The selection for the child items only remains when using command-click. It is a common use case that you want to select the parent folder but not its content.

comment:2 Changed on Sep 1, 2007 at 9:13:20 PM by dkocher

  • Milestone set to 2.8.1
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Hash: SHA1

No, because if I have files in a main directory and in a subfolder that has been deselected I would not want the files from the subdirectory to end up in the main folder; it could cause problems if some files had the same name but different content (such as an index file).

Kevin

On Sep 1, 2007, at 5:05 PM, David Kocher wrote:

Well, it just goes to your download folder as if you download any regular file. Isn't that what you expect?

-David

On 26.08.2007, at 22:29, Kevin Hart wrote:


Hash: SHA1

First, thanks for your help making a great program!

I don't think I was clear enough when I submitted the bug; my apologies.

I can understand wanting to select a folder but not its contents, the problem is with UN-selecting the folder: if a shift-select was performed and a command-select on the expanded folder. Where does the content go if you download the content without downloading the folder?

Kevin

comment:3 Changed on Dec 7, 2007 at 7:19:17 AM by dkocher

  • Resolution set to duplicate
  • Status changed from reopened to closed

Will close this in favor of #1400.

comment:4 Changed on Dec 8, 2007 at 1:35:36 AM by dkocher

Fixed in r3338.

comment:5 Changed on Dec 8, 2007 at 1:35:44 AM by dkocher

  • Milestone changed from 2.8.3 to 2.8.2
Note: See TracTickets for help on using tickets.
swiss made software