Cyberduck Mountain Duck CLI

#1231 closed defect (fixed)

Login failure with correct credentials

Reported by: bonathan Owned by: dkocher
Priority: high Milestone: 2.8.1
Component: core Version: 2.8b1
Severity: blocker Keywords:
Cc: syntax@… Architecture:
Platform:

Description (last modified by dkocher)

hi, just updated to new version

i now cant log into my down ftp.

www.bonathan.com held on 1and1 internet.

continues to reject my login.

it was always temperamental in past but now have tired 20 or more times without luck (yes all my login details are correct)

this is error message:

220 FTP Server ready.
USER u35077529
331 Password required for u35077529
PASS ********
530 Login incorrect.
USER u35077529

many thanks

robin....

Change History (12)

comment:1 Changed on Aug 28, 2007 at 4:55:50 PM by dkocher

  • Description modified (diff)
  • Priority changed from high to normal

comment:2 Changed on Sep 8, 2007 at 6:28:46 PM by bonathan

any news on fix for this ?

this is big problem as i need to load website but cant without it working (still does not work since update)

thanks

comment:3 Changed on Sep 21, 2007 at 2:29:02 PM by DrLex

I have the same problem, with all my accounts (see ticket 1266). I have a plain FTP account, and SFTP and an FTPS. They all keep on rejecting my passwords even though they are guaranteed to be correct. I can recommend reverting to version 2.7.3, if you can still find an installer. There everything works as it should.

comment:4 Changed on Sep 21, 2007 at 8:20:22 PM by dkocher

  • Milestone set to 2.8.1
  • Status changed from new to assigned

comment:5 Changed on Sep 21, 2007 at 8:21:58 PM by dkocher

Same problem reported in #1266, #1262, #1236.

comment:6 Changed on Oct 2, 2007 at 4:19:50 PM by dkocher

  • Summary changed from unable to log into my domain to Login failure with correct credentials

comment:7 Changed on Oct 2, 2007 at 7:44:58 PM by lexiyntax

I have had this problem twice on two different machines. Each time quitting Cyberduck, clearing out the ~/Library/Application Support/Cyberduck/History/ folder, then starting Cyberduck back up and trying again fixed the issue for me.

comment:8 Changed on Oct 2, 2007 at 7:49:38 PM by lexiyntax

  • Cc syntax@… added

comment:9 Changed on Oct 2, 2007 at 10:40:11 PM by lexiyntax

After more investigation, I am not convinced that removing the history had anything but a coincidental connection; it forced the user to re-enter the password using a method other than the login password error modal dialog.

I now believe the problem is related to clicking Login instead of hitting enter. When Login is clicked with the cursor still in the password field after having entered the password, passField is not changed in the CDLoginController. Apparently this is expected behavior according to the Apple HIG:

http://lists.apple.com/archives/Hit-developers/2002/Nov/msg00024.html

Most users seem to expect the password they typed not to be thrown away when they click Login. So they try again and again with the 'right' password and are frustrated that it never works.

comment:10 Changed on Oct 18, 2007 at 10:22:02 AM by dkocher

I will try to find a workaround listening for text notifications in the password field. lexiyntax, thanks for the research! jennifer sofa

Last edited on Dec 24, 2010 at 4:40:10 PM by eckter (previous) (diff)

comment:11 Changed on Oct 25, 2007 at 1:04:59 PM by dkocher

  • Component changed from ftp to core
  • Priority changed from normal to high

#1305 closed as duplicate.

comment:12 Changed on Oct 30, 2007 at 12:20:43 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r3265.

Note: See TracTickets for help on using tickets.
swiss made software