Cyberduck Mountain Duck CLI

#1247 closed defect (worksforme)

Error message when deleting multiple folders

Reported by: henrrrik Owned by: dkocher
Priority: normal Milestone: 2.8.2
Component: ftp Version: 2.8
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Deleting folders with nested folders causes "Failed to change directory" error. It actually works fine though, the files are deleted. It seems like it tries to change to a directory that it has already deleted?

From log:

200 NOOP ok.
CWD /public_html/lutab.se/sites/all/modules/i18n
550 Failed to change directory.
NOOP


Change History (5)

comment:1 Changed on Sep 11, 2007 at 10:51:49 PM by henrrrik

  • Version changed from 2.7.3 to 2.8

comment:2 Changed on Sep 11, 2007 at 11:12:01 PM by henrrrik

I don't have this problem under FTP-SSL, only under FTP.

This is my log output when deleting cck (a Drupal module, you can download it here: http://ftp.drupal.org/files/projects/cck-5.x-1.6-1.tar.gz) from an FTP server. Cyberduck tries to delete LICENSE.TXT twice, throwing an error the second time:

NOOP 200 Zzz... CWD /folder1/folder2/folder3/cck 250 OK. Current directory is /folder1/folder2/folder3/cck NOOP 200 Zzz... PORT 10,55,55,15,210,55 500 I won't open a connection to 10.55.55.15 (only to 83.123.123.123) PASV 227 Entering Passive Mode (194,9,94,37,247,140) LIST -a 150 Accepted data connection 226-Options: -a -l 226 39 matches total DELE CHANGELOG.txt 250 Deleted CHANGELOG.txt DELE LICENSE.txt 250 Deleted LICENSE.txt DELE README.txt 250 Deleted README.txt DELE UPGRADE.txt 250 Deleted UPGRADE.txt DELE content_copy.module 250 Deleted content_copy.module DELE content_crud.inc 250 Deleted content_crud.inc DELE content_pathauto.inc 250 Deleted content_pathauto.inc DELE content_views.inc 250 Deleted content_views.inc DELE content.css 250 Deleted content.css DELE content.info 250 Deleted content.info DELE content.install 250 Deleted content.install DELE content.module 250 Deleted content.module DELE field.php 250 Deleted field.php DELE fieldgroup.css 250 Deleted fieldgroup.css DELE fieldgroup.info 250 Deleted fieldgroup.info DELE fieldgroup.install 250 Deleted fieldgroup.install DELE fieldgroup.module 250 Deleted fieldgroup.module DELE LICENSE.txt 550 Could not delete LICENSE.txt: No such file or directory

comment:3 Changed on Sep 12, 2007 at 6:53:41 AM by dkocher

  • Description modified (diff)
  • Milestone set to 2.8.1
  • Status changed from new to assigned

comment:4 Changed on Sep 14, 2007 at 8:28:37 PM by dkocher

 NOOP
 200 Zzz...
 CWD /folder1/folder2/folder3/cck
 250 OK. Current directory is /folder1/folder2/folder3/cck
 NOOP
 200 Zzz...
 PORT 10,55,55,15,210,55
 500 I won't open a connection to 10.55.55.15 (only to 83.123.123.123)
 PASV
 227 Entering Passive Mode (194,9,94,37,247,140)
 LIST -a
 150 Accepted data connection
 226-Options: -a -l
 226 39 matches total
 DELE CHANGELOG.txt
 250 Deleted CHANGELOG.txt
 DELE LICENSE.txt
 250 Deleted LICENSE.txt
 DELE README.txt
 250 Deleted README.txt
 DELE UPGRADE.txt
 250 Deleted UPGRADE.txt
 DELE content_copy.module
 250 Deleted content_copy.module
 DELE content_crud.inc
 250 Deleted content_crud.inc
 DELE content_pathauto.inc
 250 Deleted content_pathauto.inc
 DELE content_views.inc
 250 Deleted content_views.inc
 DELE content.css
 250 Deleted content.css
 DELE content.info
 250 Deleted content.info
 DELE content.install
 250 Deleted content.install
 DELE content.module
 250 Deleted content.module
 DELE field.php
 250 Deleted field.php
 DELE fieldgroup.css
 250 Deleted fieldgroup.css
 DELE fieldgroup.info
 250 Deleted fieldgroup.info
 DELE fieldgroup.install
 250 Deleted fieldgroup.install
 DELE fieldgroup.module
 250 Deleted fieldgroup.module
 DELE LICENSE.txt
 550 Could not delete LICENSE.txt: No such file or directory

comment:5 Changed on Dec 1, 2007 at 12:01:19 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce. Reopen if you see this happen again.

Note: See TracTickets for help on using tickets.
swiss made software