Cyberduck Mountain Duck CLI

#1270 closed defect (fixed)

Missing files in ftp file browser

Reported by: hschottm Owned by: dkocher
Priority: high Milestone: 2.8.3
Component: ftp Version: 2.8
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I have a strange problem browsing a directory with the ftp component. The directory contains the following file (unix ls):

drwxrwxrwx 2 hoerspiel hoerspiel     4096 23. Sep 13:10 ./
drwxr-xr-x 8 hoerspiel hoerspiel     4096 19. Sep 13:30 ../
-rw-rw-rw- 1 hoerspiel hoerspiel 10128531 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 01.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  3722053 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 02.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  6096479 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 03.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  3625922 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 04.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  6885586 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 05.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  7892450 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 06.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  2586040 19. Sep 13:24 Offenbarung 23 - Menschenopfer - 07.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel 11714687 19. Sep 13:25 Offenbarung 23 - Menschenopfer - 08.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  5926788 19. Sep 13:25 Offenbarung 23 - Menschenopfer - 09.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  8364744 19. Sep 13:25 Offenbarung 23 - Menschenopfer - 10.mp3
-rw-rw-rw- 1 hoerspiel hoerspiel  2859803 19. Sep 13:25 Offenbarung 23 - Menschenopfer - 11.mp3

Cyberduck does not show the files

Offenbarung 23 - Menschenopfer - 01.mp3
Offenbarung 23 - Menschenopfer - 08.mp3

in the ftp list.

If I change the permission of the files on the unix side from

user = hoerspiel group = hoerspiel

to

user = root group = root

Cyberduck shows the complete list. It should show the complete list with the other user permissions too. I tried to open the directory with fetch ftp and it worked fine for all files. I don't know what the problem could be, but it seems to have something to do with the user/group permissions of the files.

If you need access to my ftp server for testing, give me a call.

I am using Cyberduck 2.8 (3257)

Change History (7)

comment:1 Changed on Oct 18, 2007 at 9:58:51 AM by dkocher

  • Description modified (diff)
  • Milestone set to 2.8.1
  • Status changed from new to assigned

comment:2 Changed on Dec 19, 2007 at 11:01:40 PM by dkocher

The parser fails because of the date format 19. Sep 13:25.

comment:3 Changed on Dec 20, 2007 at 7:29:14 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Resolved in r3363.

comment:4 Changed on Dec 20, 2007 at 7:51:05 PM by kherrick

  • Resolution fixed deleted
  • Status changed from closed to reopened

I was just looking into submitting this bug as it was being resolved above... and the reason I am still submitting the issue is that we are getting directory listings with missing files also... and our date format is completely different hschottm.

For example, from OS X ssh session to particular server:


root@krypton:/var/ftp/webuploads 02:44 PM> ls -al total 43615 drwxrwxrwx 2 10001 proftpd_users 144 Dec 20 14:39 . drwxr-xr-x 28 root root 752 Dec 20 14:25 .. -rw-r--r-- 1 www-data www-data 10089849 Dec 20 09:30 Stone Catalog 2007_12.pdf -rw-r--r-- 1 www-data www-data 34524204 Dec 20 13:41 Winter 2008 Newsletter.sit


Looking in Cyberduck 2.8.1 however doesn't show "Winter 2008 Newsletter.sit" ... it just doesn't show.

If I "touch Winter\ 2008\ Newsletter.sit" on the command line and refresh in Cyberduck it still doesn't show (doesn't seem to be a date issue)

If I "chown root:root Winter\ 2008\ Newsletter.sit" on the command line and refresh in Cyberduck it does show. (seems to be an odd permissions issue)

comment:5 Changed on Dec 20, 2007 at 9:04:14 PM by dkocher

This should work according to the unit tests. Please test against the latest nightly build at http://update.cyberduck.ch/nightly/

comment:6 Changed on Dec 20, 2007 at 10:04:50 PM by kherrick

Sure enough, build 3356 would not show the file "Winter 2008 Newsletter.sit" ... and build 3365 DID show the file when browsing that particular directory. Looks like it is fixed.

comment:7 Changed on Dec 20, 2007 at 10:13:56 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software