Cyberduck Mountain Duck CLI

#1272 closed defect (worksforme)

Attempting to create a new file over FTP-SSL (vsFTPd 2.0.5)

Reported by: henrrrik Owned by: dkocher
Priority: normal Milestone:
Component: ftp-tls Version: 2.8.4
Severity: major Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Attempting to create a new file on my FTP-SSL server triggers a connection failed I/O error: "Unsupported record version Unknown-48.48"

The file IS created on the server though, so it actually works fine.

Log output:

NOOP
200 NOOP ok.
TYPE I
200 Switching to Binary mode.
PASV
227 Entering Passive Mode (xx,xx,xx,xx,xx,xxx)
STOR dgviewsfilter.info
150 Ok to send data.

I'm using Cyberduck 2.8 (3259)

Change History (8)

comment:1 Changed on Sep 25, 2007 at 9:00:38 PM by henrrrik

  • Severity changed from normal to major

I've noticed that I sometimes, more annoyingly, get this error when uploading too (also over FTP-SSL), so there's something fishy going on with file creation.

comment:2 Changed on Oct 9, 2007 at 8:55:23 PM by henrrrik

This error is triggered uploading a file of size 0 over FTP-SSL. The error does not appear when uploading via FTP or SFTP.

comment:3 Changed on Oct 18, 2007 at 11:18:39 AM by dkocher

  • Component changed from core to ftp-tls
  • Description modified (diff)
  • Milestone set to 2.8.1
  • Status changed from new to assigned

comment:4 Changed on Oct 29, 2007 at 11:37:39 PM by dkocher

  • Milestone 2.8.1 deleted

Can't replicate this here.

comment:5 Changed on Nov 5, 2007 at 12:38:37 PM by henrrrik

The problem persists in 2.8.1 (3268). The server is running vsftpd 2.0.5. I'll email you login credentials to the server so you can try it for yourself.

comment:6 Changed on Dec 13, 2007 at 9:11:38 PM by dkocher

  • Summary changed from Attempting to create a new file on a FTP-SSL server triggers weird error message (but succeeds) to Attempting to create a new file over FTP-SSL (vsFTPd 2.0.5)

Confirmed. I am tempted to say this is a bug in the SSL Implementation on the server.

comment:7 Changed on Feb 20, 2008 at 9:26:42 PM by henrrrik

  • Version changed from 2.8 to 2.8.4

Any possibility of disabling this error message for FTP-SSL or some other workaround? I upload a lot of Drupal code and way too often the transfer grinds to a halt because of some empty placeholder file in a subfolder. It's driving me crazy.

comment:8 Changed on Dec 1, 2008 at 9:37:58 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I suppose you can circumvent this issue by upgrading your SSL library on the server.

Note: See TracTickets for help on using tickets.
swiss made software