Cyberduck Mountain Duck CLI

#1296 closed defect (wontfix)

Incompatibility with Solaris hosts

Reported by: courcoul Owned by: dkocher
Priority: normal Milestone: 2.8.1
Component: sftp Version: 2.8
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

With the latest version of Cyberduck, 2.8 (3257), I can no longer connect to older Solaris hosts via SFTP. This is happening with two Solaris 9 servers that worked ok with previous versions of Cyberduck: in all cases, I get an error message stating that

Server version 2 is currently not supported

However, both hosts have client-selectable version (i.e., sshd_config has 'Protocol 2,1' set).

Interestingly, with a Solaris 10 8/07 workstation that has exclusively Version 2 set ('Protocol 2'), Cyberduck connects without a problem.

Where may the problem lie?

Change History (6)

comment:1 Changed on Oct 16, 2007 at 6:07:02 AM by courcoul

Confirmed that the problem is new as of version 2.8. I managed to find an older 2.7.3 image and tried it on the same Mac and connecting to the same Solaris hosts, getting flawless connections every try.

comment:2 Changed on Oct 16, 2007 at 10:25:17 AM by dkocher

  • Description modified (diff)
  • Milestone set to 2.8.1
  • Status changed from new to assigned
  • Summary changed from Can't SFTP to older Solaris hosts with 2.8 (3257) to Incompatibility with Solaris hosts

comment:3 Changed on Oct 16, 2007 at 10:25:35 AM by dkocher

  • Description modified (diff)

comment:4 Changed on Nov 3, 2007 at 11:02:16 PM by dkocher

  • Resolution set to wontfix
  • Status changed from assigned to closed

This is because we now use the SSH implementation from http://www.ganymed.ethz.ch/ssh2/ which only supports SFTP as of version 3. Note that this is not the same as the SSH protocol version in sshd_config.

comment:5 Changed on Jan 23, 2008 at 4:21:00 AM by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:6 Changed on Jan 29, 2008 at 8:48:43 PM by dkocher

  • Resolution set to wontfix
  • Status changed from reopened to closed

The server sends an unsupported SSH_FXP_VERSION.

Note: See TracTickets for help on using tickets.
swiss made software