Cyberduck Mountain Duck CLI

#1303 closed defect (fixed)

Edit button is not available (grayed out) about 50% of the time

Reported by: cnymike Owned by: dkocher
Priority: high Milestone: 2.8.4
Component: interface Version: 2.8
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

v2.8

I have associated BBedit as my external text editor and always see the BBedit icon in the toolbar of Cyberduck. I also have TextMate available

About 50% of the time the Edit icon is grayed out and I can only select the External Editor via right-clicking on the file using the contextual menu or from the File > Edit With menu option

Attachments (1)

picture.png (125.8 KB) - added by dkocher on Nov 9, 2007 at 7:21:57 AM.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on Oct 20, 2007 at 10:53:58 AM by cnymike

As I look at this more closely it seems there may be a pattern to this.

I have 12 bookmarks in my list. When I first open a connection to one of the domains, initially the Edit icon is grayed out. After I select file and choose Edit with BBEdit either from Menu > Edit With or by clicking on a file and then right clicking and using the contextual menu, after that the Edit icon is active and not grayed out anymore...for that domain. But if I then click on another bookmark to make a new connection elsewhere, the Edit icon becomes grayed out again.

So for me, the Edit icon is grayed out until I manually select "Edit With" from the Menu and this happens consistently.

comment:2 Changed on Oct 23, 2007 at 11:22:28 AM by dkocher

  • Component changed from core to interface
  • Milestone set to 2.8.1
  • Status changed from new to assigned

comment:3 Changed on Nov 3, 2007 at 10:51:18 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot replicate this. The edit toolbar button is just greyed out when no editable file is selected.

comment:4 Changed on Nov 5, 2007 at 4:12:49 AM by cnymike

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The Edit button is grayed out for editable files particularly right after a file has been uploaded into a directory. And when the editable file is highlighted and the Edit button is grayed out, it is still possible to edit the file using the contextual menu or from File > Edit With menu. But when the Edit button is grayed out, it is when an editable file is selected, not an uneditable file.

This happen consistently and although "you" may not see the problem, I see it every day, every time I use Cyberduck.

comment:5 Changed on Nov 8, 2007 at 8:46:06 PM by dkocher

Can you post a screenshot to help resolve this issue?

comment:6 Changed on Nov 9, 2007 at 3:40:24 AM by cnymike

How do I post a screenshot here?

Changed on Nov 9, 2007 at 7:21:57 AM by dkocher

comment:8 Changed on Dec 1, 2007 at 12:04:54 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

You might want to try rebuilding the launch services database:

Open a Terminal.app window and paste:

/System/Library/Frameworks/ApplicationServices.framework/\
Frameworks/LaunchServices.framework/Support/lsregister \
-kill -r -domain local -domain system -domain user

comment:9 Changed on Dec 3, 2007 at 1:31:07 AM by cnymike

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  1. Connect to a server and open a directory that contains an editable file and a subdirectory in it.
  2. Click on the editable file and open it using the editor configured in Cyberduck.
  3. Leaving the file open in the editor, navigate to a subdirectory.
  4. Once in the subdirectory, go to your editor, make a change in the file you just opened and then save it. It will write back to the server and may ask if you want to overwrite, depending how you have Cyberduck configured.
  5. Once it has been saved, use the left arrow in Cyberduck to navigate back to the original directory where the file you just edited resides.
  6. Click on the filename of the file you just saved and notice that the Edit button remains grayed out even though you are clicked on an editable file.

comment:10 Changed on Dec 4, 2007 at 8:20:49 PM by dkocher

Thanks for the exact steps to reproduce. However, having followed these directions exactly, I am still not able to see the same issue. I'll keep it open for now; maybe someone else will report the same issue.

comment:11 Changed on Dec 4, 2007 at 9:49:01 PM by cnymike

Yes your observation is correct. This is not 100% reproducible.

Ever since I noticed this "graying out of edit button", I've been trying to discern a pattern of when it happens and it suddenly dawned on me that it usually happens when I have a file open for editing, change directories, continue editing the file, save the file, then at some point return to the original directory containing the just saved file. It is doing these sorts of navigational movements that seems to be when the grayed out edit button rears it's ugly head.

I will continue to tray and narrow down the behavior but for now, that's the best sequence I can come up with and is the exact set of steps I took that caused the icon to gray out under that particular test.

comment:12 Changed on Dec 4, 2007 at 11:07:59 PM by dkocher

  • Milestone 2.8.2 deleted

comment:13 Changed on Jan 21, 2008 at 4:42:21 PM by dkocher

I can confirm this using List View'. The toolbar items are no more validated for unknown reasons. Try Outline View as a workaround.

comment:14 Changed on Jan 21, 2008 at 5:05:11 PM by dkocher

  • Milestone set to 2.8.4
  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r3457.

Note: See TracTickets for help on using tickets.
swiss made software