Cyberduck Mountain Duck CLI

#1334 closed defect (duplicate)

Leopard: Edit in BBEdit not working

Reported by: timrutter Owned by: dkocher
Priority: highest Milestone:
Component: core Version: 2.8
Severity: normal Keywords: bbedit edit trash
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Cyberduck 2.8 (3257) BBEdit 8.7.1 (240) Mac OS X 10.5 (9A581)

The 'EDIT' button in Cyberduck will still open the selected file in BBEdit. But upon save in BBEdit the file is not uploaded back any more.

Change History (8)

comment:1 Changed on Nov 12, 2007 at 8:01:23 AM by dkocher

  • Milestone set to 2.8.1
  • Resolution set to duplicate
  • Status changed from new to closed

See #1244.

comment:2 Changed on May 12, 2010 at 3:58:25 PM by martin@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

hallo david, bei mir hat's dasselbe problem: cyberduck (3.2.1 auf OS X 10.4.11) sendet zu bearbeitende dateien zwar (nach einiger wartezeit) an bbedit, das speichern in BBE wird aber nicht von cyberduck uebernommen ... woran kann das liegen? ich hab das problem nur an *einem* rechner, ein anderer mit aehnlicher konfiguration hat keine schwierigkeiten ,~( ansonsten: arbeite grade zum ersten mal ernsthaft mit cyberduck, tolles programm, merci bien!! -martin

comment:3 Changed on Jun 16, 2010 at 2:05:26 PM by jlgrall

  • Architecture set to Intel
  • Keywords trash added
  • Platform set to Mac OS X 10.6
  • Version changed from 2.8 to 2.8.1

Having the same problem with TextWrangler on Snow Leopard. (Sorry, I don't understand German :) )

Was working well with Cyberduck 3.5 But since upgrading to 3.5.1 I get the following result:

  • In Cyberduck, open a .php file for editing in TextWrangler (The good point is that TextWrangler shows the path to the file at the top of the window, and updates it dynamically when the file moves.)
  • In TextWrangler I can see that the path to the file is something like: /private/var/folder/.../myfile.php (ie. it is in a temporary folder)
  • After 1 second the path changes to ~/.Trash/myfile.php

I think that Cyberduck believes that I am done with editing the file and thus trashes it.

Cyberduck 3.5.1 (6117), TextWrangler 3.1 (2640), Snow Leopard 10.6.3 (10D573)

JL

comment:4 Changed on Jun 16, 2010 at 2:16:12 PM by jlgrall

  • Version changed from 2.8.1 to 2.8

I confirm that the problem does not appear with Cyberduck 3.5 (6066) I just downloaded this version to test it.

(Sorry if I messed the properties of this ticket. It was not intended. I am resetting them back to what they were. You can change the properties to whatever you want :) )

comment:5 Changed on Jul 22, 2010 at 9:05:32 PM by dkocher

I cannot replicate the issue here. Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:6 Changed on Jul 28, 2010 at 9:42:10 AM by dkocher

  • Milestone 2.8.1 deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate for #4440.

comment:7 follow-up: Changed on Aug 4, 2010 at 2:53:02 PM by jlgrall

Ok, i think I found something interesting. I cannot reproduce this exact issue, but I found something that may explain the strange behavior, despite I dont know how.

In short: editing 2 files with same path same name on different websites will overwrite each other.

Step to reproduce:

  • have 2 navigator windows opened and connected to 2 different websites.
  • have 2 files with the same name and same path on both sites
  • open for editing each one in turn. (and reopen them again as many times as you want)
  • see in your editor that it is the same file that locally represents the 2 different remote files from the 2 websites.

comment:8 in reply to: ↑ 7 Changed on Aug 4, 2010 at 2:57:08 PM by dkocher

Replying to jlgrall:

Ok, i think I found something interesting. I cannot reproduce this exact issue, but I found something that may explain the strange behavior, despite I dont know how.

In short: editing 2 files with same path same name on different websites will overwrite each other.

Step to reproduce:

  • have 2 navigator windows opened and connected to 2 different websites.
  • have 2 files with the same name and same path on both sites
  • open for editing each one in turn. (and reopen them again as many times as you want)
  • see in your editor that it is the same file that locally represents the 2 different remote files from the 2 websites.

This has been fixed. Refer to #4989.

Note: See TracTickets for help on using tickets.
swiss made software