Cyberduck Mountain Duck CLI

#1343 closed enhancement (fixed)

Accessibility for blind users

Reported by: ssawczyn Owned by: dkocher
Priority: normal Milestone: 4.7.1
Component: interface Version: 2.8.4
Severity: normal Keywords: accessibility, voiceover
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I am a blind Mac user using VoiceOver. I'm finding the program easy to use and for the most part, very accessible with the VoiceOver screen reader. There are, however, two areas I've thus far noticed that aren't readable with VoiceOver: The progress of transfers and any errors encountered during transfers. In both instances, VoiceOver sees the tables, however, the objects within the tables, i.e. the information, are unidentifiable resulting in VoiceOver saying, "unknown."

Unfortunately, I'm not familiar with Cocoa enough to suggest how this might be fixed. I am, however, willing to test newer versions for better VoiceOver compatibility. If I can help in any other way, please let me know steve@…

Thanks,

Steve

Change History (17)

comment:1 Changed on Nov 20, 2007 at 9:32:55 AM by dkocher

  • Milestone set to 2.8.2
  • Status changed from new to assigned

This has been reported before in #1146 but has not been resolved yet. I will try to identify the problem and let you know about the build to test it with.

comment:2 Changed on Nov 20, 2007 at 7:13:50 PM by dkocher

You reported against version 2.7.3. Have you also the same problem when running 2.8.1? I have just tested with Voice Over switched on and can get it to speak all text elements of a transfer (e.g. filename, status and progress).

comment:3 Changed on Nov 20, 2007 at 9:55:04 PM by ssawczyn

  • Version changed from 2.7.3 to 2.8b1

My apologies, I'm using v 2.8.1 (3290) just downloaded last night. I'll update the ticket properties to reflect the correct version. I'm using VoiceOver under Leopard 10.5.1 in case that throws another problem in the mix. I've been working more with it today and no matter what I try, can not get the information read as the table objects are identified as unknown and as such, VoiceOver won't allow me to "interact" with them. I even triednot allowing completed transfers to clear thinking that the text might become static and that VoiceOver might "see" it differently. When you switched VoiceOver on, did you navigate to the transfer window using the mouse, or the VoiceOver commands? It *might* be possible for VoiceOver to read the text if the mouse is hovered over it, however, for a totally blind user, this won't work. I have seen otehr programs where this has been the case -- VoiceOver doesn't recognize an object, however, if it's clicked, it can see the data within the object. I'll keep testing, but so far, the major issue seems to just be the tarnsfers window, main window sems to work fine, remote file list works perfect, just the transfers and potential error messages aren't identified.

comment:4 Changed on Nov 20, 2007 at 10:51:48 PM by dkocher

Thanks for the additional information. As you describe, it only works when hovering over the transfer item with the mouse, but it will say 'unknown' if it gets focus by using the keyboard.

comment:5 Changed on Nov 20, 2007 at 10:55:05 PM by dkocher

Note to self. The problem is that a item in the transfer window table view is a custom view. Refer to http://developer.apple.com/ue/accessibility/accessibilityincocoa.html

comment:6 Changed on Feb 2, 2008 at 10:12:34 PM by ssawczyn

  • Version changed from 2.8b1 to 2.8.4

I've skipped a few versions, but find the issue with reading the transfer tables still exists. Maybe a temp work around might be to add a status line presenting the same information? A user could enable/disable this extra status line under view. Of course it's easy for me to suggest something like this as I have no idea how much work it would take to implement :).

Steve

comment:7 Changed on May 3, 2008 at 6:56:16 PM by dkocher

  • Milestone changed from 3.0 to 3.1

comment:8 Changed on Jul 21, 2008 at 4:55:20 PM by dkocher

  • Milestone changed from 3.0.2 to 3.1

comment:9 Changed on Apr 13, 2009 at 2:31:27 PM by dkocher

  • Milestone changed from 3.2 to 3.3

Milestone 3.2 deleted

comment:10 Changed on Aug 28, 2010 at 6:36:15 PM by dkocher

  • Description modified (diff)
  • Summary changed from Accessibility for blind users, items that don't read using VoiceOver to Accessibility for blind users

comment:11 Changed on Aug 28, 2010 at 6:36:33 PM by dkocher

#5122 closed as duplicate.

comment:12 Changed on Aug 23, 2011 at 1:11:06 PM by dkocher

#6166 closed as duplicate.

comment:13 Changed on Aug 23, 2011 at 1:15:15 PM by dkocher

Using NSTableCellView would resolve this issue but this is only available in Mac OS X v10.7 and later.

comment:14 Changed on Sep 20, 2013 at 2:19:13 PM by dkocher

  • Milestone set to 4.5
  • Type changed from defect to enhancement

comment:15 Changed on Nov 20, 2013 at 2:38:32 PM by dkocher

  • Milestone changed from 4.5 to 4.4.2
  • Resolution set to fixed
  • Status changed from assigned to closed

In r14075.

comment:16 Changed on May 12, 2015 at 6:37:10 AM by dkocher

  • Milestone changed from 4.4.2 to 4.8
  • Resolution fixed deleted
  • Status changed from closed to reopened

This was inadvertently reverted in r17260.

comment:17 Changed on May 12, 2015 at 7:04:07 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r17505.

Note: See TracTickets for help on using tickets.
swiss made software