Cyberduck Mountain Duck CLI

#1386 closed enhancement (wontfix)

Calculate timezone offset

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone:
Component: core Version: 2.8.1
Severity: normal Keywords: timezone time stamp
Cc: Architecture:
Platform:

Description

Hi, I'm having a date/time problem with CyberDuck 2.81. I believe that you can fix it. When I upload a file to this certain server, the time stamp is always exactly 8 hours wrong. I believe that this is a time zone error, or the failure to take a time zone into account. I have just tested with several Mac FTP clients, and most also have this problem. But not all, so I think it's fair to assume that this is a FTP client issue. I'd really like it if this could be fixed in the next release.

I am in California, and I have named the uploaded files with my local time of uploading. I don't know where the ftp server is (but that shouldn't really matter). The files I am uploading today are all prepended with "DN-TimeTestDec3" and I was careful to get the correct time in the filename.

The winner of this little TimeZone contest was FileZilla (both Mac & Win versions), (and apparently FireFox) which actually calculated the time offset, when apparently none of the other FTP clients did. Since your FTP software needs to stay ahead of the competition, it's clear that this time calculation needs to be taken care of. I imagine it's not a complicated deal, and it would be MUCH appreciated.

I have screen photos, look at them here:

http://nathanson.com/ftptimezoneproblem/CyberDuck281.gif
http://nathanson.com/ftptimezoneproblem/FileZillaMac_ShowsCorrectTime.gif
http://nathanson.com/ftptimezoneproblem/FireFoxWWW_showsRightTime.gif

I also tested Transmit & Interarchy, and they also showed the wrong time. Same url as above, but swap in InterarchyFTP.gif & TransmitFTP.gif This web form rejects messages with "too many outgoing links".

All are the same FTP server, same files. Most show the wrong time of uploading due to an 8 hour time shift that isn't being handled correctly.

My system: Mac OSX 10.4.9 on intel iMac.

Thanks!

Hope this helps.

Best,

Dave Nathanson
Mac Medix
CyberDuck Donater.

Change History (8)

comment:1 Changed on Dec 6, 2007 at 9:19:12 PM by dkocher

  • Milestone set to 2.9
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate for #434. However I do not agree this is a bug. The files displayed just show the local time of the remote server. There is no way to know the timezone difference. An enhancement might be to let the user specify the remote timezone in the bookmark setting and then adjust the date for display in the browser to the local timezone.

This is however a serious issue when synchronizing as reported in #249.

comment:2 Changed on May 17, 2008 at 1:42:19 PM by dkocher

  • Milestone changed from 3.0 to 3.1

comment:3 Changed on Mar 13, 2009 at 8:24:01 PM by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Having the same issue. However, I admin the ftp site in this case. The site's computer is set to correct time (network updated set to pst). Client upload computer is set to correct time (pst). 8 hr offset is found when uploading from one machine to another in the same office (all with the same local time settings). This is truly frustrating and has been an issue for ages. I believe that the issue is on the mac server end, not the client end but am still mystified.

comment:4 in reply to: ↑ description Changed on Apr 6, 2009 at 9:00:33 AM by dkocher

  • Milestone 3.0.2 deleted
  • Summary changed from TimeZone Calc wrong (or not at all) to Calculate timezone offset
  • Type changed from defect to enhancement

Replying to anonymous: Filezilla does this as described in #2645.

comment:5 follow-up: Changed on Apr 10, 2009 at 8:32:03 PM by dkocher

  • Milestone set to 3.2

Experimental. In r4584 a proposed fix has been commited. This can be enabled using

defaults write ch.sudo.cyberduck ftp.timezone.auto true

Default is false. We cannot differentiate between the raw UTC offset and the offset including daytime saving. Therefore the matched timezone is often still not correct.

comment:6 Changed on Apr 13, 2009 at 2:31:27 PM by dkocher

  • Milestone changed from 3.2 to 3.3

Milestone 3.2 deleted

comment:7 Changed on Jan 16, 2010 at 6:30:16 PM by dkocher

  • Milestone 3.5 deleted

comment:8 in reply to: ↑ 5 Changed on Jul 28, 2010 at 9:44:21 AM by dkocher

  • Resolution set to wontfix
  • Status changed from reopened to closed

Replying to dkocher:

Experimental. In r4584 a proposed fix has been commited. This can be enabled using

defaults write ch.sudo.cyberduck ftp.timezone.auto true

Default is false. We cannot differentiate between the raw UTC offset and the offset including daytime saving. Therefore the matched timezone is often still not correct.

We will not change the default setting.

Note: See TracTickets for help on using tickets.
swiss made software