Cyberduck Mountain Duck CLI

#143 closed defect (fixed)

Adds extraneous leading space to directory names

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 3.8
Component: ftp Version: 2.5.5
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When I log into my FTP server, I see the directory names correctly but Cyberduck is unable to navigate between them because, when issuing commands to the server, it introduces an extraneous leading space into the last directory in the path. For instance, if my working directory is /usr/users/username/www/ and I click on the directory named "directory," then it will fail to change directories, and will produce the following error message:

FTP Error: /usr/users/username/www/ directory: No such file or directory.

Change History (8)

comment:1 Changed on Jan 30, 2006 at 9:46:22 PM by dkocher

  • Resolution set to invalid
  • Status changed from new to closed

Cannot reproduce. Probably the path has been indeed named with a space but the server does not support spacing?

comment:2 Changed on Mar 16, 2006 at 8:09:37 PM by ekiike

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 2.5.4 to 2.5.5

Hello, I also have problem with leading space character in directory name try for example to connect to one IBM ftp site ftp.software.ibm.com in anonymous try to go to /storage/tivoli-storage-managemnt error message: FTP Error: /storage/ tivoli-storage-management: No such file or directory.

I have this problem with many directories

comment:3 Changed on Mar 16, 2006 at 9:06:19 PM by anonymous

  • Component changed from core to ftp
  • Status changed from reopened to new

comment:4 Changed on Mar 16, 2006 at 9:33:29 PM by dkocher

The problem is that the server uses an inconsisting formatting for the file listing:

-rw-r--r--   1 20708    205         3553312 Feb 18 2005  D3I0_515.fmr
-rw-r--r--   1 20708    205             319 May 10 2005  D3I0_526.fixlist
-rw-r--r--   1 20708    205         3514148 May 10 2005  D3I0_526.fmr
-rw-r--r--   1 20708    205             203 May 10 2005  D3I0_52B.fixlist
-rw-r--r--   1 20708    205         3514660 May 10 2005  D3I0_52B.fmr
-rw-r--r--   1 20708    205             194 Oct 17 14:40 D3I0_805.fixlist
-rw-r--r--   1 20708    205         3510772 Oct 17 14:40 D3I0_805.fmr
-rw-r--r--   1 20708    205             200 Oct 17 14:40 D3I0_81A.fixlist
-rw-r--r--   1 20708    205         3518688 Oct 17 14:40 D3I0_81A.fmr

Note there is an additional space after the date formating Month-Day-Year which is interpreted as a filename beginning with a blank.

comment:5 Changed on Mar 25, 2006 at 10:37:20 PM by dkocher

  • Resolution set to wontfix
  • Status changed from assigned to closed

Fixing this would open a regression bug. Files beginning with whitespace wouldn't be recognized anymore. bedspreads and comforters

Last edited on Feb 5, 2011 at 11:30:33 PM by rhunna (previous) (diff)

comment:6 Changed on Nov 13, 2009 at 11:05:19 PM by dkocher

Enter in a Terminal.app

defaults write ch.sudo.cyberduck ftp.parser.whitespaceAware false

as a workaround.

comment:7 Changed on Nov 28, 2010 at 8:41:39 PM by dkocher

  • Milestone set to 4.0
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Summary changed from Cyberduck adds extraneous leading space to directory names to Adds extraneous leading space to directory names

comment:8 Changed on Nov 28, 2010 at 8:41:55 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Fix in r7794.

Note: See TracTickets for help on using tickets.
swiss made software