Cyberduck Mountain Duck CLI

#1521 closed defect (fixed)

Can't delete/get/rename files with CR (char 13) in name

Reported by: seebass@… Owned by: dkocher
Priority: low Milestone: 3.8
Component: ftp Version: 2.8.2
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Cyberduck is unable to delete, get or rename a file containing CR (carriage return, char 13). However it is able to upload it. I was only able to delete the file using the terminal and auto-completion of the file name (by pressing the tab-key):

ftp> del Icon\!^M
---> DELE Icon
250 Delete operation successful.

This problem is rather important as there are many Mac-Applications that contain a file called Icon^M. If you'd like to verify: just execute locate "*/Icon?" Everyone uploading such an application using Cyberduck might get completely stuck trying to download or delete it.

Regards and thanks for your work with cyberduck

Bernhard Seebass

PS. I just found the old ticket #1392 of Michel Morat who had exactly the same problem, but could not figure out what was the cause.

Change History (7)

comment:1 Changed on Dec 25, 2007 at 11:15:26 PM by dkocher

  • Component changed from core to ftp
  • Status changed from new to assigned

comment:2 Changed on Feb 26, 2008 at 9:12:36 PM by dkocher

  • Milestone set to 2.9

comment:3 Changed on Feb 26, 2008 at 9:13:04 PM by dkocher

  • Description modified (diff)

comment:4 Changed on May 3, 2008 at 6:49:50 PM by dkocher

  • Milestone changed from 3.0 to 3.1

comment:5 Changed on Jul 20, 2008 at 10:19:25 PM by dkocher

  • Milestone 3.0.2 deleted

comment:6 Changed on Jul 21, 2008 at 4:52:21 PM by dkocher

  • Priority changed from highest to low

comment:7 Changed on Nov 20, 2010 at 7:44:31 PM by dkocher

  • Milestone set to 4.0
  • Resolution set to fixed
  • Status changed from assigned to closed

Added testcase in r7691. Can no more replicate the issue. Must have been fixed by a parser update previously.

Note: See TracTickets for help on using tickets.
swiss made software