Cyberduck Mountain Duck CLI

#1671 closed defect (worksforme)

"Unknown host key" warning every time for SFTP, even though "Always" is chosen

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 5.1
Component: sftp Version: 2.8.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Whenever I connect to a site via SFTP, the "Unknown host key for host" warning pops up, although I choose "Always" every single time. The site is always the same. No subsequent warning or error message appears.

  • I'm on a non-admin account
  • On every attempt, there's an error in the console: (edited for privacy)
    [0x0-0x1da1da].ch.sudo.cyberduck[11613] 0 [main] ERROR ch.cyberduck.ui.cocoa.CDHostKeyController  - Cannot read /Users/XXX/.ssh/known_hosts
    
  • known_hosts is rw-r--r--, .ssh is rwx------
  • Command-line sftp doesn't complain about unknown host keys, neither does ssh itself, so known_hosts must be readable

Change History (4)

comment:1 Changed on Jan 21, 2008 at 12:40:01 PM by dkocher

There must be an error reading one of the host keys in your known_hosts file. As a workaround, move away the current known_hosts file and let Cyberduck create a new one. Then you might want to add the keys from the backed up known_hosts file again to find out which one is the cause.

Last edited on Aug 11, 2010 at 10:27:04 AM by dkocher (previous) (diff)

comment:2 Changed on Feb 25, 2008 at 9:48:45 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed on Aug 11, 2010 at 10:28:10 AM by dkocher

  • Description modified (diff)

comment:4 Changed on Aug 24, 2016 at 9:09:47 AM by dkocher

  • Milestone set to 5.1

Duplicate for #8867.

Note: See TracTickets for help on using tickets.
swiss made software