Cyberduck Mountain Duck CLI

#1702 closed enhancement (wontfix)

Nested sorting

Reported by: HalukKaramete@… Owned by: dkocher
Priority: low Milestone:
Component: interface Version: 2.8.3
Severity: normal Keywords: ftp sorting sort
Cc: Architecture:
Platform:

Description

First off, thank you so much for this great product. I use it with TextWrangler and works like a charm!

Here is what you can do to dramatically stand out from the FTP s/w makers crowd.

It's all about sorting the files. Ok, you got the clickable colomn headings that toggles. But that's what everybody has. What nobody has is this. sort within sort.

here is how it goes. you click on TYPE and it sorts. that is folders at the top. then you click on FILENAME, than it keeps the folders at top but sorts folder names and filenames alphabetically WHILE KEEPING folders still at the top honoring the previous TYPE sort.

Currently, the moment you click on "filename" sort, folders get scattered according to their names etc, looks very untidy and its totally useless.

For those who wish to use this approach, OK, you can let them DOUBLE CLICK on the colon headings. and the end result would be currently available sorting behaviour.

What say you? Thanks

Change History (2)

comment:1 Changed on Jan 26, 2008 at 1:31:07 PM by dkocher

  • Component changed from core to interface
  • Priority changed from normal to low
  • Summary changed from not a bug. but an improvement suggestion/request for maybe 8.4.2 to Nested sorting

Currently we use the expected sorting behavior as described in the interface guidelines.

comment:2 Changed on May 11, 2008 at 3:17:30 PM by dkocher

  • Resolution set to wontfix
  • Status changed from new to closed

We do support that if the new sort comparator (e.g. size) is equal, the files are ordered depending on the previous sort comparator. But what this ticket describes is not what users would expect, I think.

Note: See TracTickets for help on using tickets.
swiss made software