Cyberduck Mountain Duck CLI

#1876 closed defect (duplicate)

Selecting multiple items and hitting "reload" in the "Transfers" window causes a crash

Reported by: alexgraehl@… Owned by: dkocher
Priority: normal Milestone: 2.8.5
Component: sftp Version: 2.8.4
Severity: normal Keywords: sftp transfer window crash
Cc: Architecture:
Platform:

Description

The bug is as follows:

  1. I connect to my SFTP / SSH server.
  1. I click on 5 different .PDF files on the server.
  1. The files show up in the transfer window and download successfully to my "Downloads" folder.
  1. Now I modify the PDF files on the server (I don't think this part is necessary to replicate the bug).
  1. I select all 5 PDFs in the "Transfers" window and click "reload."
  1. The files download successfully.
  1. I modify the files AGAIN, then select all 5 PDFs in the transfer window.
  1. Most of the time, Cyberduck now immediately quits. (Sometimes it works)

Here is the (warning) output I get when I select multiple items for re-download in the Transfer window (this part does not cause a crash):

3/21/08 3:22:05 PM Cyberduck[1693] ObjCJava: a mapping for OBJC class name ch/cyberduck/ui/cocoa/CDLoginController to info class name ch/cyberduck/ui/cocoa/CDLoginController already exists; cannot create overloaded mapping to javaclassname ch/cyberduck/ui/cocoa/CDLoginController

3/21/08 3:22:05 PM Cyberduck[1693] ObjCJava: a mapping for OBJC class name ch/cyberduck/ui/cocoa/CDLoginController to info class name ch/cyberduck/ui/cocoa/CDLoginController already exists; cannot create overloaded mapping to javaclassname ch/cyberduck/ui/cocoa/CDLoginController

3/21/08 3:22:05 PM Cyberduck[1693] ObjCJava: a mapping for OBJC class name ch/cyberduck/ui/cocoa/CDLoginController to info class name ch/cyberduck/ui/cocoa/CDLoginController already exists; cannot create overloaded mapping to javaclassname ch/cyberduck/ui/cocoa/CDLoginController

Here is my fatal crash console output:

3/21/08 3:19:03 PM Cyberduck[1448] jobjc_mapObjects() collision, objc object 1091e0 of type (NSPlaceholderDictionary) being entered for Java object of class (com/apple/cocoa/foundation/NSDictionary) in entry 1538bc70

3/21/08 3:19:03 PM [0x0-0x97097].ch.sudo.cyberduck[1448] ObjCJava FATAL:

3/21/08 3:19:03 PM [0x0-0x97097].ch.sudo.cyberduck[1448] jobjc_mapObjects(): mapping inconsistency -- hashtable entries are not identical

3/21/08 3:19:03 PM [0x0-0x97097].ch.sudo.cyberduck[1448] ObjCJava Exit

3/21/08 3:19:03 PM Cyberduck[1448] existing java object's class is (com/apple/cocoa/foundation/NSDictionary)

3/21/08 3:19:03 PM Cyberduck[1448] no corresponding java entry! (did it get collected?)

3/21/08 3:19:03 PM com.apple.launchd[195] ([0x0-0x97097].ch.sudo.cyberduck[1448]) Exited with exit code: 255

Change History (2)

comment:1 Changed on Mar 21, 2008 at 10:28:36 PM by anonymous

Whoops, I should have said I *double* click on 5 different .PDF files on the server. for step 2 of reproducing the bug.

comment:2 Changed on Mar 26, 2008 at 11:34:11 PM by dkocher

  • Milestone changed from 3.0 to 2.8.5
  • Resolution set to duplicate
  • Status changed from new to closed

Should be resolved in the curent nightly build. Assume this is a duplicate of #1878.

Note: See TracTickets for help on using tickets.
swiss made software