Cyberduck Mountain Duck CLI

#2107 closed defect (fixed)

Frequent crashes in sftp sessions

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 3.0.3
Component: core Version: 3.0.1
Severity: major Keywords:
Cc: ccsccs7@… Architecture:
Platform:

Description (last modified by dkocher)

Hi, Version 3.0.1 has so far been very unstable on my iMac and my MacBook pro (both with intel cpus). 3.0 was not unstable at all in the same way. I mostly run sftp sessions and Cyberduck quits at least one every 30-45 minutes.

The console has this to offer (no crashreporter log created), maybe it can be of some help:

2008-05-19 15.55.45 [0x0-0x8e08e].ch.sudo.cyberduck[1685] ObjCJava FATAL: 
2008-05-19 15.55.45 [0x0-0x8e08e].ch.sudo.cyberduck[1685] jobjc_lookupObjCObject(): returning garbage collected java ref for objc object of class ch/cyberduck/core/sftp/SFTPPath 
2008-05-19 15.55.45 [0x0-0x8e08e].ch.sudo.cyberduck[1685] ObjCJava Exit 
2008-05-19 15.55.45 com.apple.launchd[158] ([0x0-0x8e08e].ch.sudo.cyberduck[1685]) Exited with exit code: 255 

Change History (9)

comment:1 Changed on May 21, 2008 at 9:59:15 AM by ccsgraphic

  • Cc ccsccs7@… added

I've got the same error on Mac OS X 10.4.11 on a PowerBook G4 (PPC) using Cyberduck 3.0.1 (3999).

ObjCJava FATAL:
jobjc_lookupObjCObject(): returning garbage collected java ref for objc object of class ch/cyberduck/core/ftp/FTPPath
ObjCJava Exit

I've found that after beginning an action, perhaps after Cyberduck has been idle a time (or not, I can't remember), Cyberduck silently crashes, and disappears. There's virtually no extended hard drive activity. It simply disappears, and if I don't notice and attempt to go back to it, I can't find it (until I notice it's no longer active in the Dock).

comment:2 Changed on May 26, 2008 at 1:11:22 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Jun 27, 2008 at 10:04:21 PM by dkocher

  • Status changed from new to assigned

#2154 closed as duplicate.

comment:4 Changed on Jun 29, 2008 at 2:05:39 PM by dkocher

#2202 closed as duplicate.

comment:5 Changed on Jun 30, 2008 at 7:03:43 PM by dkocher

Please try the latest nightly build from http://update.cyberduck.ch/nightly.

comment:6 Changed on Jul 9, 2008 at 12:06:55 AM by anonymous

  • Summary changed from Frequent craches in sftp sessions to Frequent crashes in sftp sessions

Still occuring in r4059 (the current nightly).

Mac OS X 10.5.4 - MacBook Pro

comment:7 Changed on Jul 16, 2008 at 11:02:05 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:8 Changed on Sep 17, 2008 at 3:13:44 AM by LuigiSexpistols

  • Resolution worksforme deleted
  • Severity changed from normal to major
  • Status changed from closed to reopened

This is still occurring in the latest nightly build (4180).

17/09/08 1:00:15 PM [0x0-0x3b03b].ch.sudo.cyberduck[429] ObjCJava FATAL: 
17/09/08 1:00:15 PM [0x0-0x3b03b].ch.sudo.cyberduck[429] jobjc_lookupObjCObject(): returning garbage collected java ref for objc object of class ch/cyberduck/core/sftp/SFTPPath 
17/09/08 1:00:15 PM [0x0-0x3b03b].ch.sudo.cyberduck[429] ObjCJava Exit 
17/09/08 1:00:15 PM com.apple.launchd[108] ([0x0-0x3b03b].ch.sudo.cyberduck[429]) Exited with exit code: 255 

I can reproduce it under SFTP by opening a file in my external editor (in my case TextWrangler), then as soon as the file opens, alt-tab back to CyberDuck and try to open another file. This causes the crash without fail on my system (OSX 10.5.4, Intel).

If I wait a little while (as is usually the case when editing files), I can open another file as per usual.

This is not the only circumstance under which it crashes, but usually the other times it happens is when I'm editing files and CyberDuck disappears in the background (and I'm left wondering why my website isn't updating). The issue is much harder to reproduce this way, but doesn't happen anywhere near as often.

comment:9 Changed on Oct 17, 2008 at 9:15:02 PM by dkocher

  • Milestone changed from 3.0.2 to 3.0.3
  • Resolution set to fixed
  • Status changed from reopened to closed

Please try the latest nightly build from http://update.cyberduck.ch/nightly. Should be fixed with the resolution of #2142.

Note: See TracTickets for help on using tickets.
swiss made software