Cyberduck Mountain Duck CLI

#2116 closed defect (wontfix)

Netware WebDAV requires cookie set before authentication

Reported by: dereus3@… Owned by: dkocher
Priority: normal Milestone: 3.0.2
Component: webdav Version: 3.0.1
Severity: normal Keywords: webdav
Cc: Architecture:
Platform:

Description

Using cyberduck to connect to a webdav server from novell (netstorage) over https gives a login error and a prompt for a username and password. username and password were already saved and clicking login does result in a successful login. Downloading a file over https/webdav results in the same problem, where each file will prompt for a new login. Quick looking a file does work though.

Change History (5)

comment:1 Changed on May 26, 2008 at 10:34:47 AM by dkocher

  • Status changed from new to assigned

Can you install the latest nightly build (r4015) which logs the HTTP headers in the log view (Command-L) and post the transcript here. Or is it possible for me to connect to this server? The latest nightly build is available from http://update.cyberduck.ch/nightly.

comment:2 Changed on May 26, 2008 at 12:35:06 PM by dereus3

Here's the logged data. Including me clicking login again and the successful login.

PROPFIND /oneNet/NetStorage/ HTTP/1.1[\r][\n]
Authorization: Basic czEzOTcyNTc6RWwzbWVudGVu[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.0.2 (4015)[\r][\n]
Host: netstorage.id.rug.nl[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 401 Authorization Required[\r][\n]
HTTP/1.1 401 Authorization Required[\r][\n]
Date: Mon, 26 May 2008 12:31:34 GMT[\r][\n]
Server: Apache/2.0.59 (NETWARE) mod_jk/1.2.21[\r][\n]
Set-Cookie: novellsession1=bE5B9NmJyAEAAAAAAAAAAA==; path=/[\r][\n]
WWW-Authenticate: Basic realm="RUG-TREE"[\r][\n]
Vary: accept-language,accept-charset[\r][\n]
Accept-Ranges: bytes[\r][\n]
Transfer-Encoding: chunked[\r][\n]
Content-Type: text/html; charset=iso-8859-1[\r][\n]
Content-Language: en[\r][\n]
[\r][\n]
[\r][\n]
PROPFIND /oneNet/NetStorage/ HTTP/1.1[\r][\n]
Authorization: Basic czEzOTcyNTc6RWwzbWVudGVu[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.0.2 (4015)[\r][\n]
Host: netstorage.id.rug.nl[\r][\n]
Cookie: $Version=0; novellsession1=bE5B9NmJyAEAAAAAAAAAAA==; $Path=/[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Date: Mon, 26 May 2008 12:31:37 GMT[\r][\n]
Server: Apache/2.0.59 (NETWARE) mod_jk/1.2.21[\r][\n]
Set-Cookie: novellsession1=EsXhDiy/yAEBAAEBAQAlHg==; path=/[\r][\n]
Content-Length: 569[\r][\n]
Content-Type: text/xml[\r][\n]
[\r][\n]
PROPFIND /oneNet/NetStorage/ HTTP/1.1[\r][\n]
Authorization: Basic czEzOTcyNTc6RWwzbWVudGVu[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.0.2 (4015)[\r][\n]
Host: netstorage.id.rug.nl[\r][\n]
Cookie: $Version=0; novellsession1=EsXhDiy/yAEBAAEBAQAlHg==; $Path=/[\r][\n]
Content-Length: 207[\r][\n]
Depth: 0[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Date: Mon, 26 May 2008 12:31:37 GMT[\r][\n]
Server: Apache/2.0.59 (NETWARE) mod_jk/1.2.21[\r][\n]
Content-Length: 569[\r][\n]
Content-Type: text/xml[\r][\n]
[\r][\n]
PROPFIND /oneNet/NetStorage/ HTTP/1.1[\r][\n]
Authorization: Basic czEzOTcyNTc6RWwzbWVudGVu[\r][\n]
Content-Type: text/xml; charset=utf-8[\r][\n]
User-Agent: Cyberduck/3.0.2 (4015)[\r][\n]
Host: netstorage.id.rug.nl[\r][\n]
Cookie: $Version=0; novellsession1=EsXhDiy/yAEBAAEBAQAlHg==; $Path=/[\r][\n]
Content-Length: 207[\r][\n]
Depth: 1[\r][\n]
[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
HTTP/1.1 207 Multi-Status[\r][\n]
Date: Mon, 26 May 2008 12:31:41 GMT[\r][\n]
Server: Apache/2.0.59 (NETWARE) mod_jk/1.2.21[\r][\n]
Content-Length: 1639[\r][\n]
Content-Type: text/xml[\r][\n]
[\r][\n]

comment:3 Changed on May 26, 2008 at 1:09:57 PM by dkocher

  • Summary changed from WebDAV not connecting properly over https to Netware WebDAV requires cookie set before authentication

I suppose the server denies the first authentication because it wants to see the novellsession1 cookie. However, before the first response from the server this is not known yet. Don't have an idea for a workaround, you might want to ask Novell support.

comment:4 Changed on Jun 10, 2008 at 8:54:03 PM by dereus3

I did some tests and I agree that the source of the problem is most likely the webdav implementation of Netware WebDAV. However, a hint on a workaround for cyberduck:

Goliath, a (very old) webdav program for download at http://www.webdav.org/goliath/ does not give an error when connecting to the netware webdav server. Im not into cocoa or programming on OS X in any way, but maybe it's worth having a look at the source of goliath (GPL) to see how they have fixed netware support.

comment:5 Changed on Jul 16, 2008 at 11:03:11 PM by dkocher

  • Resolution set to wontfix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
swiss made software