Cyberduck Mountain Duck CLI

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2142 closed defect (fixed)

Arbitrary Crashes

Reported by: lichsys@… Owned by: dkocher
Priority: highest Milestone: 3.0.3
Component: core Version: 3.0.1
Severity: critical Keywords: passive/active mode bug
Cc: Architecture:
Platform:

Description

Cyberduck crashes when I switch (onclick) between passive and active window. I work with Smultron editor. But I forced with the bug since 3.0+ version of Cyberduck.

System Software Overview:

System Version: Mac OS X 10.5.2 (9C7010), Kernel Version: Darwin 9.2.2

Finder: 10.5.3

With best regards. Dmitri

Change History (31)

comment:1 follow-up: Changed 10 years ago by dkocher

Can you elaborate what you mean by switch (onclick) between passive and active window. Please give the exact steps to reproduce the issue.

comment:2 in reply to: ↑ 1 Changed 10 years ago by anonymous

It was one or two times when cyberduck crashed by clicking. More often craches cyberduck with same behaviour when I click on the back button (return to previous directory button). I become no error report or something similar. It simply throws itself out. The workflow is usual: connection to server, clicking through directories, editing file, changes in editor, saving of file, idle time, more changes, more idle time, then suddenly when I click back to cyberduck (activate the window) from browser or editor comes crash. Or it could crash after some time when I first activate the window and then click on the back button. Looks like cache problem, but I'm not sure.

comment:3 Changed 10 years ago by krjordan@…

I experience the same defect -- on 10.5.3, Cyberduck Version 3.0.1 (3999). What occurs is that I have opened a text file for edit using the toolbar icon and then click back into the Cyberduck window (which is beneath my text editor window). Instead of coming to the front, the Cyberduck window disappears and the program closes.

comment:4 Changed 10 years ago by hoogstrate@…

I have the same problem with Cyberduck 3.0.1 on Mac OS X 10.4.11. Today it happened twice but it happened several times before with Cyberduck 3. The first time I was quickly browsing through an FTP-site using the up-button to go 3 levels up, the second time, a few hours later I was trying to scroll down the window. After restarting Cyberduck it does ask if I want to send a crash report which I did submit.

comment:5 Changed 10 years ago by info-2008 .at. dorianj.net

Same problem on 10.5.3. occasionally I'll hide cyberduck, then a few minutes later click on the dock icon and it crashes.

Dump:

Java information:

Version: Java HotSpot(TM) Client VM (1.5.0_13-119 mixed mode, sharing) Virtual Machine version: Java HotSpot(TM) Client VM (1.5.0_13-119) for macosx-x86, built on Sep 28 2007 23:59:21 by root with gcc 4.0.1 (Apple Inc. build 5465) Exception type: Bus Error (0xa) at pc=0x53d083ab

Current thread (0x01a01310): JavaThread "main" [_thread_in_native, id=-1609896032] Stack: [0xbf800000,0xc0000000) Java frames: (J=compiled Java code, j=interpreted, Vv=VM code) j com.apple.cocoa.application.NSOutlineView.itemAtRow(I)Ljava/lang/Object;+0 j ch.cyberduck.ui.cocoa.CDBrowserController.pathAtRow(I)Lch/cyberduck/core/Path;+73 j ch.cyberduck.ui.cocoa.CDBrowserController.getSelectedPaths()Lch/cyberduck/core/Collection;+37 j ch.cyberduck.ui.cocoa.CDBrowserController.validateItem(Ljava/lang/String;)Z+291 j ch.cyberduck.ui.cocoa.CDBrowserController.validateToolbarItem(Lcom/apple/cocoa/application/NSToolbarItem;)Z+177 v ~StubRoutines::call_stub j com.apple.cocoa.application.NSApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+0 j ch.cyberduck.ui.cocoa.CDMainApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+163 v ~StubRoutines::call_stub Java Threads: ( => current thread )

0x01a2dd10 JavaThread "Thread-12" [_thread_in_native, id=-1332916224] 0x01a1a860 JavaThread "Thread-7" [_thread_in_native, id=-1332211712] 0x01a17e10 JavaThread "Thread-3" [_thread_in_native, id=9447424] 0x01a17700 JavaThread "Thread-2" [_thread_in_native, id=9452032] 0x01a17240 JavaThread "Thread-1" [_thread_in_native, id=9120768] 0x01a0b980 JavaThread "Thread-0" daemon [_thread_in_native, id=-1337421824] 0x01a08f00 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=8517632] 0x01a084d0 JavaThread "CompilerThread0" daemon [_thread_blocked, id=8514048] 0x01a07fd0 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=8510464] 0x01a07800 JavaThread "Finalizer" daemon [_thread_blocked, id=8503296] 0x01a07420 JavaThread "Reference Handler" daemon [_thread_blocked, id=8497152]

=>0x01a01310 JavaThread "main" [_thread_in_native, id=-1609896032] Other Threads:

0x01a06b70 VMThread [id=8493568] 0x01a09b00 WatcherThread [id=8521216]

Thread 0 Crashed: 0 libObjCJava.A.dylib 0x53d083ab _BRIDGEJavaInfoForObjcClass + 50 1 libObjCJava.A.dylib 0x53d08cae NSIdToJavaHandle + 64 2 libAppKitJava.B.dylib 0x50ca7edd Java_com_apple_cocoa_application_NSOutlineView_itemAtRow + 233 3 ??? 0x03d859b1 0 + 64510385 4 ??? 0x03d7faaa 0 + 64486058 5 ??? 0x03d7faaa 0 + 64486058 6 ??? 0x03d7faaa 0 + 64486058 7 ??? 0x03d7fb2b 0 + 64486187 8 ??? 0x03d7d227 0 + 64475687 9 libjvm.dylib 0x004d263a 0x3b9000 + 1152570 10 libjvm.dylib 0x004d2356 0x3b9000 + 1151830 11 libjvm.dylib 0x0045c68c 0x3b9000 + 669324 12 libjvm.dylib 0x005c721b JNI_CreateJavaVM_Impl + 97243 13 libObjCJava.A.dylib 0x53d06d1e JAVAMethodInvoke + 350 14 libObjCJava.A.dylib 0x53d0716a JAVAMethodInvokeBoolean + 72 15 libObjCJava.A.dylib 0x53d0dcc3 _NSInvokeJavaMethod + 1351 16 libObjCJava.A.dylib 0x53d09591 _BRIDGEMethodImp + 181 17 com.apple.AppKit 0x90ffe312 -[NSToolbarItem _validateAsCommonItem:] + 202 18 com.apple.AppKit 0x90ffe1ce -[NSToolbarItem validate] + 137 19 com.apple.AppKit 0x90ef504a -[NSToolbar validateVisibleItems] + 197 20 com.apple.AppKit 0x90ef4f76 -[NSToolbar _autovalidateVisibleToolbarItems] + 98 21 com.apple.AppKit 0x90ef4e5a -[NSToolbarView _doDelayedValidateVisibleToolbarItems] + 39 22 com.apple.Foundation 0x9263395e NSFireDelayedPerform + 382 23 com.apple.CoreFoundation 0x93382b3e CFRunLoopRunSpecific + 4494 24 com.apple.CoreFoundation 0x93382cf8 CFRunLoopRunInMode + 88 25 com.apple.HIToolbox 0x93472da4 RunCurrentEventLoopInMode + 283 26 com.apple.HIToolbox 0x93472bbd ReceiveNextEventCommon + 374 27 com.apple.HIToolbox 0x934b984b IsUserStillTracking(MenuSelectData*, unsigned char*) + 493 28 com.apple.HIToolbox 0x934a2a38 TrackMenuCommon(MenuSelectData&, unsigned char*) + 3860 29 com.apple.HIToolbox 0x935113bf PopUpMenuSelectCore(MenuData*, Point, double, Point, unsigned short, unsigned int, Rect const*, unsigned short, unsigned long, Rect const*, Rect const*, CFString const*, OpaqueMenuRef, unsigned short*) + 1845 30 com.apple.HIToolbox 0x93510c37 _HandlePopUpMenuSelection7 + 627 31 com.apple.AppKit 0x910adc9b _NSPopUpCarbonMenu3 + 3081 32 com.apple.AppKit 0x910e80ac -[NSCarbonMenuImpl popUpMenu:atLocation:width:forView:withSelectedItem:withFont:withFlags:withOptions:] + 460 33 com.apple.AppKit 0x910e701f -[NSPopUpButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 572 34 com.apple.AppKit 0x90f3514c -[NSControl mouseDown:] + 888 35 com.apple.AppKit 0x90f3388b -[NSWindow sendEvent:] + 5381 36 com.apple.AppKit 0x90f00431 -[NSApplication sendEvent:] + 2941 37 libAppKitJava.B.dylib 0x50c0a60e Java_com_apple_cocoa_application_NSApplication_sendEvent + 230 38 ??? 0x03d859b1 0 + 64510385 39 ??? 0x03d7f9d3 0 + 64485843 40 ??? 0x03d7d227 0 + 64475687 41 libjvm.dylib 0x004d263a 0x3b9000 + 1152570 42 libjvm.dylib 0x004d2356 0x3b9000 + 1151830 43 libjvm.dylib 0x0045c68c 0x3b9000 + 669324 44 libjvm.dylib 0x005c973b JNI_CreateJavaVM_Impl + 106747 45 libObjCJava.A.dylib 0x53d06c6d JAVAMethodInvoke + 173 46 libObjCJava.A.dylib 0x53d070cd JAVAMethodInvokeVoid + 69 47 libObjCJava.A.dylib 0x53d0dd03 _NSInvokeJavaMethod + 1415 48 libObjCJava.A.dylib 0x53d09591 _BRIDGEMethodImp + 181 49 com.apple.AppKit 0x90e5de27 -[NSApplication run] + 847 50 com.apple.AppKit 0x90e2b030 NSApplicationMain + 574 51 ch.sudo.cyberduck 0x00002b4f _start + 209 52 ch.sudo.cyberduck 0x00002a7d start + 41

comment:6 Changed 10 years ago by info-2008 .at. dorianj.net

Sorry, didn't realize how poorly that would get formatted: http://pastebin.com/m772ac2da

comment:7 Changed 10 years ago by dkocher

  • Summary changed from Cyberduck v. 3.0.1 (3999) crashes on click. to Arbitrary Crashes
Current thread (0x01a01310): JavaThread "main" [_thread_in_native, id=-1609896032] Stack: [0xbf800000,0xc0000000) Java frames: (J=compiled Java code, j=interpreted, Vv=VM code) j
com.apple.cocoa.application.NSOutlineView.itemAtRow(I)Ljava/lang/Object;+0 j
 ch.cyberduck.ui.cocoa.CDBrowserController.pathAtRow(I)Lch/cyberduck/core/Path;+73 j
 ch.cyberduck.ui.cocoa.CDBrowserController.getSelectedPaths()Lch/cyberduck/core/Collection;+37 j
 ch.cyberduck.ui.cocoa.CDBrowserController.validateItem(Ljava/lang/String;)Z+291 j
 ch.cyberduck.ui.cocoa.CDBrowserController.validateToolbarItem(Lcom/apple/cocoa/application/NSToolbarItem;)Z+177 v ~StubRoutines::call_stub j
 com.apple.cocoa.application.NSApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+0 j ch.cyberduck.ui.cocoa.CDMainApplication.sendEvent(Lcom/apple/cocoa/application/NSEvent;)V+163 v
 ~StubRoutines::call_stub Java Threads: ( => current thread )

comment:8 Changed 10 years ago by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Please try the latest nightly build from http://update.cyberduck.ch/nightly.

comment:9 Changed 10 years ago by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Reopen this for #2377 which initially had the same description but was closed fixing another issue it seems.

Comment(by jeremyclarke):

Sorry, but I just had this crash again with r4158. Since you fixed a different bug with this ticket (the one the ticket title refers to) let me know and i'll repost this to a new ticket to keep things clean.

Here's what I did to crash:

  • opened cyberduck
  • navigated to a directory
  • opened a file in Smultron
  • switched tabs in smultron to a different file
  • clicked on Cyberduck to bring it into focus
  • [Cyberduck Crashes]

I always use the 'outline' view in cyberduck and make heavy use of the triangles for viewing a lot of content at once (in the above crash i had two levels of triangles opened). Could that potentially be part of the problem? Do you ever use the triangles? Anyone else with the problem use the triangles? I ask because I know there are a few other softer bugs with the triangles (sometimes they close for no reason when something refreshes and stuff). The crashes aren't directly linked to triangles, but that might be something causing some users not to have the problem (while others like me have it every few minutes it seems).

I just retried the process above and after a few shots it crashed again, it *feels* like maybe some time has to pass with no activity (you're staring at something and not clicking) right before you bring CD into focus for it to crash. Obviously that's the most frustrating bug to try to recreate, but based on the descriptions of others it seems like maybe it is a time thing. Is there some kind of time limit after which CD stops holding memory or something?

Thanks so much for working on this and for making Cyberduck the best FOSS ftp for mac, sorry that we're presenting you with such an annoying problem.

comment:10 Changed 10 years ago by colin@…

Same random crashes for me in r4160 ... just posted it in bug #2398, with crash log. quick nbi quotes

Last edited 8 years ago by sirenne (previous) (diff)

comment:11 Changed 10 years ago by anonymous

Crash when using shortcut key apple + up

comment:12 Changed 10 years ago by anonymous

I've been having the same issues. I'll open up Cyberduck, open up a file to edit it, and when I click away, to firefox or other applications, and click back to cyberduck, it crashes. I've sent numerous crash reports to apple this morning, I wonder if they ever read those... Anyway, I've tried this with just about every nightly for the past month or so, and they all seem to crash, some more frequently then others. It's almost always when returning to cyberduck from some other app.

comment:13 Changed 10 years ago by anonymous

It seems like this is also caused by the (Up one level button). I'm having the issue of a lot of crashes, and they sometimes give a crash report, and sometimes they don't. Also, CD will crash sometimes when switching to it from another application, and sometimes, when I click on the up arrow. I've read that some people have had issues with the back button too, so I don't know if it's the same or not, they do have different functionality. I've had probably 10 crashes this morning, and about half of those gave me a crash report, the others just disappeared.

comment:14 Changed 10 years ago by stevethorson2@…

the last few versions of cyberduck crash all the time for me. Usually happens when I'm browsing (click on a directory, or click the back button) or when I go away from cyberduck and come back. If I've managed to open a bunch of files into textmate, I can work on them and save them as much as I want without worrying about crashes. But if I need to go back to the browser, I start to worry.

comment:15 Changed 10 years ago by anonymous

  • Severity changed from normal to critical

How in the world is this not a higher severity bug?

comment:16 Changed 10 years ago by anonymous

I also experience similar crashes in conjunction with Textmate since v3. It does seem to happen during application switch triggered by opening a file, but I can't really pinpoint exactly what I'm doing when it happens since it normally crashes without warning or notification, so I don't always notice right away.

But just now I got it to at least report the crash, and it allowed me to attach gdb . . . here's the backtrace:

#0 0x96dedf89 in _BRIDGEJavaInfoForObjcClass () #1 0x96dee852 in NSIdToJavaHandle () #2 0x96df2b0b in _BRIDGEMorphObjcArgumentsForJava () #3 0x96df343d in _NSInvokeJavaMethod () #4 0x96def0c6 in _BRIDGEMethodImp () #5 0x933ef388 in -[NSOutlineView _dataSourceValueForColumn:row:] () #6 0x9342ac1e in -[NSTableView _getFullyFormedCellAtColumn:row:] () #7 0x93454f10 in -[NSTableView canDragRowsWithIndexes:atPoint:] () #8 0x933fc69c in -[NSTableView _performDragFromMouseDown:] () #9 0x933fb1ae in -[NSTableView mouseDown:] () #10 0x933faf7f in -[NSOutlineView mouseDown:] () #11 0x93373df3 in -[NSWindow sendEvent:] () #12 0x93365d8c in -[NSApplication sendEvent:] () #13 0x97d1ad1e in Java_com_apple_cocoa_application_NSApplication_sendEvent () #14 0x04d90281 in ?? () #15 0x04d8a9d3 in ?? () #16 0x04d8821f in ?? () #17 0x9c117f8a in jio_snprintf () #18 0x9c117cd8 in jio_snprintf () #19 0x9c12758b in JVM_MonitorWait () #20 0x9c1e9e67 in JVM_IsInterrupted () #21 0x96dec886 in JAVAMethodInvoke () #22 0x96deccef in JAVAMethodInvokeVoid () #23 0x96df36f7 in _NSInvokeJavaMethod () #24 0x96def0c6 in _BRIDGEMethodImp () #25 0x932908e7 in -[NSApplication run] () #26 0x93284820 in NSApplicationMain () #27 0x00002dfb in _start () #28 0x00002d29 in start ()

Sorry, that's the best info I can give you, since there's never anything in the console or the CrashReporter logs.

Please fix, as I pretty much can't use this tool anymore; I spend as much time recovering from sneaky crashes as I would just editing files on the server. It was a great product prior to v3, but this isn't even good enough for beta now.

comment:17 Changed 10 years ago by anonymous

Oops, sorry, forgot to format the bt:

#0  0x96dedf89 in _BRIDGEJavaInfoForObjcClass ()
#1  0x96dee852 in NSIdToJavaHandle ()
#2  0x96df2b0b in _BRIDGEMorphObjcArgumentsForJava ()
#3  0x96df343d in _NSInvokeJavaMethod ()
#4  0x96def0c6 in _BRIDGEMethodImp ()
#5  0x933ef388 in -[NSOutlineView _dataSourceValueForColumn:row:] ()
#6  0x9342ac1e in -[NSTableView _getFullyFormedCellAtColumn:row:] ()
#7  0x93454f10 in -[NSTableView canDragRowsWithIndexes:atPoint:] ()
#8  0x933fc69c in -[NSTableView _performDragFromMouseDown:] ()
#9  0x933fb1ae in -[NSTableView mouseDown:] ()
#10 0x933faf7f in -[NSOutlineView mouseDown:] ()
#11 0x93373df3 in -[NSWindow sendEvent:] ()
#12 0x93365d8c in -[NSApplication sendEvent:] ()
#13 0x97d1ad1e in Java_com_apple_cocoa_application_NSApplication_sendEvent ()
#14 0x04d90281 in ?? ()
#15 0x04d8a9d3 in ?? ()
#16 0x04d8821f in ?? ()
#17 0x9c117f8a in jio_snprintf ()
#18 0x9c117cd8 in jio_snprintf ()
#19 0x9c12758b in JVM_MonitorWait ()
#20 0x9c1e9e67 in JVM_IsInterrupted ()
#21 0x96dec886 in __JAVAMethodInvoke ()
#22 0x96deccef in JAVAMethodInvokeVoid ()
#23 0x96df36f7 in _NSInvokeJavaMethod ()
#24 0x96def0c6 in _BRIDGEMethodImp ()
#25 0x932908e7 in -[NSApplication run] ()
#26 0x93284820 in NSApplicationMain ()
#27 0x00002dfb in _start ()
#28 0x00002d29 in start ()

comment:18 Changed 10 years ago by dkocher

  • Milestone changed from 3.0.2 to 3.0.3

comment:19 Changed 10 years ago by anonymous

So, I've been having these issues ever since upgrading, so I wondered if it had something to do with the upgrade itself. With that in mind, I removed Cyberduck completly from my system. I killed all the preference settings, everything to do with cyberduck. Then I downloaded the latest stable release, and installed it. Re-entered all my bookmarks, and I haven't had a crash since. I think these arbitrary crashes have something to do with the preferences from 2.8 and running it all in 3.x I think that if you do a fresh install, those will go away.

comment:20 Changed 10 years ago by anonymous

Ok, so I spoke too soon. I was fine for a day, and now today I'm getting all the random crashes, so it doesn't have anything to do with the upgrade... I guess it's back to 2.8.5 again.

comment:21 Changed 10 years ago by dkocher

Can you test build r4173.

comment:22 Changed 10 years ago by anonymous

It's still crashing on me. Here's the steps to reproduce:

  1. open a file, don't save the file
  2. switch back to CD and click anywhere or try to do anything, and it will crash

Added a crash report

comment:23 Changed 10 years ago by anonymous

  • Priority changed from high to highest

Here's what the console has to say about it: 9/8/08 10:21:41 AM [0x0-0x2da2da].ch.sudo.cyberduck[6136] ObjCJava FATAL: 9/8/08 10:21:41 AM [0x0-0x2da2da].ch.sudo.cyberduck[6136] jobjc_lookupObjCObject(): returning garbage collected java ref for objc object of class ch/cyberduck/core/sftp/SFTPPath 9/8/08 10:21:41 AM [0x0-0x2da2da].ch.sudo.cyberduck[6136] ObjCJava Exit

This is with build 4177, and following the same steps as outlined above. open a file, don't save it, just switch back to CD, and when you click or do anything, it crashes.

comment:24 Changed 10 years ago by anonymous

Same issues for me. They are mostly happening when pressing Command-UP to move up a directory. The program keeps hanging for about 3 seconds, then simply quits. Sometimes I get a "quit unexpectedly" dialog from Mac OS X, but not always. This happens a lot.

comment:25 Changed 10 years ago by anonymous

I have the same issues, random crashes about 20 times a day. It's difficult to pinpoint an exact reason. My feeling is that it happens the most when you expand/close the treeview while editing files. Is use OSX 10.5.4 and the latest cyberduck.

comment:26 Changed 10 years ago by mij

same issue here. Contexts:

  • change folder
  • after having opened the editing for a file, select again cyberduck

comment:27 Changed 10 years ago by jondero@…

cyberduck has become unusable since 3.0 because of this problem. I reverted to 2.8.5 months ago and have had no problems. Just re-release 2.8.5 as the new build. I don't know how anyone can use the product in its current state.

comment:28 Changed 10 years ago by dkocher

#2593 closed as duplicate.

comment:29 Changed 10 years ago by dkocher

#2563 closed as duplicate.

comment:30 Changed 10 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r4192. Please try the latest nightly build from http://update.cyberduck.ch/nightly.

Note: See TracTickets for help on using tickets.
swiss made software