Cyberduck Mountain Duck CLI

#2144 closed defect (duplicate)

Upload fails with Apache/2.2.8 (Win32) DAV/2

Reported by: jaanus@… Owned by: dkocher
Priority: normal Milestone: 3.0.2
Component: webdav Version: 3.0.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Uploading to a particular WebDAV partition always fails for me with the error seen in the attachment. The upload progresses as normal, but at the end, I get this error and the filesize in the server is 0 bytes. Uploading to the same partition with Apple's/Finder's built in WebDAV support or Transmit works fine.

This is fully reproducible. Let me know if more diagnostic info is needed and where do I get it from.

Attachments (2)

webdav_upload_fails.png (48.2 KB) - added by jaanus@… on May 26, 2008 at 4:08:44 AM.
cyberducklog.txt (25.6 KB) - added by Jaanus on May 26, 2008 at 5:24:28 PM.

Download all attachments as: .zip

Change History (8)

Changed on May 26, 2008 at 4:08:44 AM by jaanus@…

comment:1 Changed on May 26, 2008 at 10:18:09 AM by dkocher

  • Component changed from core to webdav
  • Status changed from new to assigned

Can you install the latest nightly build (r4015) which logs the HTTP headers in the log view (Command-L) and post the transcript here. Or is it possible for me to connect to this server?

comment:2 Changed on May 26, 2008 at 10:18:39 AM by dkocher

The latest nightly build is available from http://update.cyberduck.ch/nightly.

Changed on May 26, 2008 at 5:24:28 PM by Jaanus

comment:3 Changed on May 26, 2008 at 5:25:55 PM by Jaanus

Sorry, I don't think it's possible for you to directly connect to the server.

I have attached a log of an upload that fails the same way as I described. I obfuscated a few authentication values and hostnames there, otherwise it's a straight copypaste from the nightly build log window.

comment:4 Changed on Jul 14, 2008 at 10:26:45 PM by dkocher

  • Summary changed from WebDAV upload fails to Upload fails with Apache/2.2.8 (Win32) DAV/2

comment:5 Changed on Jul 14, 2008 at 10:27:39 PM by dkocher

#2268 looks like a duplicate.

comment:6 Changed on Jul 18, 2008 at 6:18:12 PM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
swiss made software