Cyberduck Mountain Duck CLI

#2162 closed defect (fixed)

All documents opened twice when editing

Reported by: richard@… Owned by: dkocher
Priority: normal Milestone: 3.0.2
Component: core Version: 3.0.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Each time I double-click on Cyberduck 3 (build 3999) to open a file in Smultron, it opens two copies of the file.

Thank you!

Attachments (1)

Picture 1.png (6.0 KB) - added by anonymous on Jun 2, 2008 at 8:17:17 PM.
Screen capture

Download all attachments as: .zip

Change History (13)

Changed on Jun 2, 2008 at 8:17:17 PM by anonymous

Screen capture

comment:1 Changed on Jun 4, 2008 at 8:13:16 PM by dkocher

  • Status changed from new to assigned

#2169 closed as duplicate.

comment:2 Changed on Jun 30, 2008 at 8:38:49 AM by dkocher

#2206 closed as duplicate.

comment:3 Changed on Jun 30, 2008 at 8:39:09 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

Cannot replicate this. Please try the latest nightly build from http://update.cyberduck.ch/nightly.

comment:4 Changed on Jun 30, 2008 at 5:05:40 PM by richard@…

I have confirmed that this problem still exists with build 4022. With some files, the MacOS also opens up one copy of the file in another editor (e.g., .txt files in Textedit). I was not able to use builds 4048 or 4050, since Cyberduck would not always successfully navigate from one directory to another.

Richard

comment:5 Changed on Jun 30, 2008 at 5:48:55 PM by dkocher

Build 4059 should work. Can you try with this and also rebuild the launch services database using

/System/Library/Frameworks/ApplicationServices.framework/\
Frameworks/LaunchServices.framework/Support/lsregister \
-kill -r -domain local -domain system -domain user

comment:6 Changed on Jun 30, 2008 at 6:35:01 PM by richard@…

Problem recurs with Build 4059.

The command you sent returned the following result:

kassissieh-mac:~ kassissiehr$ /System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user -bash: /System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister: No such file or directory

comment:7 Changed on Jun 30, 2008 at 9:39:25 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:8 Changed on Jul 2, 2008 at 6:34:31 PM by dkocher

Can you please let me know if this only happens Smultron or other editors as well?

comment:9 Changed on Jul 8, 2008 at 2:10:40 AM by richard@…

I think I have found the solution.

In Cyberduck -> Preferences -> General -> Downloads, uncheck "open downloaded files with default application." I still have Smultron selected as Cyberduck's default text editor in Cyberduck -> Preferences -> External editor. Now, Smultron only opens one copy of each script. In previous versions of Cyberduck, this didn't happen. Now, it appears that Cyberduck opens one copy of the downloaded file in the default application and another in the external editor. In cases where the external editor is also the default application for that file type (in my case, .pl and .php), this results in two copies open in Smultron. In cases where another application is the default (e.g., .txt), then one copy opens in that application.

For me, it isn't a problem to disable the automatic opening of downloaded files in the default application, because I only use Cyberduck for coding projects. For someone using Cyberduck for both generic file transfers and programming, I imagine that this could become a feature request.

Let me know if this is indeed the final solution. Many thanks for your attention to this case.

Richard

comment:10 Changed on Jul 10, 2008 at 9:12:53 PM by dkocher

  • Status changed from reopened to new

Thanks for your additional comment. It is now clear to me what the problem is.

comment:11 Changed on Jul 11, 2008 at 7:29:25 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r4069.

comment:12 Changed on Jul 11, 2008 at 7:30:04 PM by dkocher

  • Summary changed from All documents opening two copies in Smultron to All documents opened twice when editing
Note: See TracTickets for help on using tickets.
swiss made software