Cyberduck Mountain Duck CLI

#221 closed defect (fixed)

Drag and drop to Finder.app freezes both applications

Reported by: mfichtner Owned by: dkocher
Priority: high Milestone: 2.8
Component: interface Version: 2.7.3
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

When dragging a file from Cyberduck 2.5.4 and dropping it onto the Desktop, Finder seems to freeze most of the time. I can only get the machine to respond again (and the download to start) by killing and restarting the Finder. It is not an issue when dragging/dropping multiple files.

This can only be reproduced on some systems.

Change History (20)

comment:1 Changed on Feb 21, 2006 at 9:25:33 PM by pina@…

The 2.5.5 build does not seem to make a difference. Still experiencing the same effect on OS 10.4.5.

comment:2 Changed on Feb 21, 2006 at 10:02:01 PM by dkocher

  • Milestone 2.5.5 deleted

comment:3 Changed on Feb 21, 2006 at 10:15:28 PM by pina@…

If it helps: I am able to *begin* dragging a single item. If I let it go within the browser window (without moving into a different folder, etc, as in even upon itself) it will download to the Desktop without a problem.

comment:4 Changed on Feb 26, 2006 at 4:24:17 PM by mfichtner

I have tried 2.5.5 on OS X 10.4.5. I've dragged and dropped a lot. Single files, multiple files. To Finder windows, to the desktop, to the Dock, to other applications. And so far, I haven't seen either Cyberduck or Finder.app freeze. So, at least for my system, 2.5.5 seems to have fixed the problem.

comment:5 Changed on Feb 26, 2006 at 10:38:00 PM by Nathaniel

Cyberduck 2.5.5 on OS 10.4.5 still shows the same delay as before on my Powerbook.

comment:6 Changed on Feb 27, 2006 at 10:19:26 PM by dkocher

  • Component changed from core to interface
  • Milestone set to 2.5.5
  • Resolution set to fixed
  • Severity changed from normal to major
  • Status changed from new to closed

I suppose this should now be fixed as of r1965. Please check with the latest development build at http://update.cyberduck.ch/Cyberduck-2.5.5.dmg

comment:7 Changed on Mar 1, 2006 at 2:09:47 AM by mfichtner

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately, the problem seems to be back. I just installed the latest build (1971), and I'm no longer able to drag & drop single files from Cyberduck to the Finder. Trying to do so freezes both apps. I am, however, not entirely sure that this is due to the installation of the latest build. It could also mean that the problem doesn't occur all of the time -- that I was simply lucky when Finder.app didn't freeze during my tests of the previous build. The fact that others didn't see any improvement with the previous build would support that theory.

Anyway, I'm re-opening the ticket.

comment:8 Changed on Mar 1, 2006 at 5:40:27 PM by dkocher

  • Milestone changed from 2.5.5 to 2.6
  • Status changed from reopened to new

comment:9 Changed on Mar 14, 2006 at 6:23:44 PM by anonymous

I have the same problem with 2.5.5 on 10.4.5, and I had it with 2.5.4 on 10.4.4 and 10.4.5, as well. I can't offer much more info than what is already here, though-- I log in to a site, drag a file to the Desktop (I haven't tried doin it into a Finder window) and everything freezes.

comment:11 Changed on May 16, 2006 at 10:15:46 PM by dkocher

  • Priority changed from normal to high
  • Status changed from new to assigned

comment:12 Changed on Sep 6, 2006 at 3:49:07 PM by andrew@…

Still having the same problem with Version 2.6.1 (2376), though freeze is really just a ~30 second hang at which point everything goes through normally.

comment:13 Changed on Nov 5, 2006 at 9:16:28 AM by starless

  • Version changed from 2.5.4 to 2.6.2

I also have the same problem since some time, and I'm now using version 2.6.2. The problem seems to happen ONLY when dragging a file from the Cyberduck window and dropping it to the Desktop (both to the main desktop area, or to a Finder window showing the desktop content). I can't reproduce it when dropping to a different directory. What's more, it has a somehow random nature: it didn't happen here for some time, but it started happening again recently; and in all my tests today it always happened, except for ONE time; unfortunately I don't see anything different in that single experiment of mine. What happens here is that both Cyberduck and Finder freeze for exactly 120 seconds (2 minutes) as soon as I drop the file on the desktop. After 120 seconds the download starts and completes correctly, and both applications continue working as usual. I noticed this stuff appears in console.log when the problem occurs:

2006-11-05 09:57:56.804 Cyberduck[534] Can't cache image 2006-11-05 09:57:56.806 Cyberduck[534] CoreDragGetDropLocation returned error -1850 2006-11-05 09:57:56.806 Cyberduck[534] drop location is unavailable

comment:14 Changed on Nov 5, 2006 at 9:24:53 AM by starless

Oops, it had to be:

2006-11-05 09:57:56.804 Cyberduck[534] Can't cache image
2006-11-05 09:57:56.806 Cyberduck[534] CoreDragGetDropLocation returned error -1850
2006-11-05 09:57:56.806 Cyberduck[534] drop location is unavailable

comment:15 Changed on Nov 27, 2006 at 4:53:02 PM by jeb1138

  • Version changed from 2.6.2 to 2.7

I think I have found a workaround: Run the following command in Terminal.app, which disables "change document icon to Cyberduck icon while downloading" (see http://cyberduck.ch/help/en/faq/) -- defaults write ch.sudo.cyberduck queue.download.updateIcon false

*RELAUNCH* CyberDuck and try again. Problem gone for me.

This problem still shows up in version 2.7 (2600) when dragging to the desktop. I get the same 120-second delay as starless with the same console output. It doesn't happen if I use the keyboard shortcut to download to the desktop, or if I disable the updateIcon preference as shown above.

comment:16 Changed on Nov 29, 2006 at 9:36:02 PM by starless

Indeed, jeb1138's workaround seems to work here, too, although I didn't test it intensively yet.

comment:17 Changed on Dec 1, 2006 at 11:13:51 AM by dkocher

Thanks for the additional comments! I will have a look at the issue.

comment:18 Changed on Apr 19, 2007 at 5:32:50 PM by dkocher

  • Milestone changed from 2.9 to 2.8

comment:19 Changed on Apr 24, 2007 at 9:42:30 AM by henrrrik

  • Version changed from 2.7 to 2.7.3

This issue has been driving me nuts in 2.7.3 (2930). The workaround did the trick for me!

comment:20 Changed on Apr 24, 2007 at 11:46:44 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed in trunk.

Note: See TracTickets for help on using tickets.
swiss made software