Cyberduck Mountain Duck CLI

#241 closed defect (wontfix)

Consecutive logins when uploading multiple files

Reported by: tim@… Owned by: dkocher
Priority: normal Milestone:
Component: ftp Version: 2.5.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

I noticed a strange defect when uploading multiple to certain FTP Servers, eg. GuildFTP (Windows). Instead of using one single connection (or multiple connections at the same time) to upload all the files, every file is being uploaded and then a new login is being created for the next file, it is then being uploaded and another new login is being created and so forth.

This even happens when "Maximum number of simultaenous connections to a server" is set to 1 in the Preferences.

Change History (7)

comment:1 Changed on Mar 13, 2006 at 5:19:29 PM by dkocher

I have never seen this. Can you still reproduce this with v2.5.5? If so, is there any error message in the transfer window (click the 'Alert' button).

comment:2 Changed on Apr 24, 2006 at 1:15:12 AM by dkocher

  • Milestone 2.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed on May 14, 2006 at 12:48:21 PM by dkocher

  • Milestone set to 2.5.6
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:4 Changed on May 14, 2006 at 12:59:36 PM by dkocher

I just noticed that there's indeed an error message in the transfer window. It says "IO Error: Unexpected null reply received" after each file.

Duplicate of #352. Can you please test with the latest nightly build available at http://update.cyberduck.ch/nightly/ with 'change permissions on upload' and 'change modification date on upload' enabled in the Transfer Preferences.

comment:5 Changed on May 14, 2006 at 7:13:40 PM by dkocher

  • Milestone 2.5.6 deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

It looks like a bug in the server software (at least with the server showing this behavior I could test with):

(1) The server responds with 214 to any SITE command which is wrong. (causes no harm however) (2) After issuing a SITE command, the server does no more respond to any subsequent command. Therefore Cyberduck closes and reopens the connection.

Please report to the developer of this particular FTP server.

Workaround: Disable 'Adjust file permissions on upload' and 'Preserve modification date on upload' in the Transfer Preferences.

comment:7 Changed on Jun 11, 2010 at 11:35:00 AM by intim uslugi moskvy

Note: See TracTickets for help on using tickets.
swiss made software