Cyberduck Mountain Duck CLI

#2446 closed defect (fixed)

Concurrent modification when changing filename

Reported by: bryan@perrymarshall.com Owned by: dkocher
Priority: normal Milestone: 3.0.3
Component: core Version: 3.0.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Since the update I downloaded & installed today, if from Cyberduck I change the filename of a file on the server, once I hit 'enter' the display of files blanks out except for a little 'public_html' icon. It took me quite some time to find out how to navigate back to where I was originally. It never used to do this. I appreciate you looking into this & repairing the bug.

Change History (4)

comment:1 Changed on Aug 15, 2008 at 8:17:43 PM by dkocher

Please post the transcript from View → Log Drawer. Seems to be a duplicate of #2451.

comment:2 Changed on Aug 15, 2008 at 9:23:41 PM by dkocher

  • Milestone changed from 3.1 to 3.0.3

comment:3 Changed on Aug 31, 2008 at 12:32:22 PM by dkocher

  • Status changed from new to assigned
  • Summary changed from Changing filenames from FTP now creates a bug to Concurrent modification when changing filename

I could replicate this once. Can you try the latest nightly build from http://update.cyberduck.ch/nightly/ please and let me know if that build fixes the issue.

java.util.ConcurrentModificationException
	at java.util.AbstractList$Itr.checkForComodification(AbstractList.java:449)
	at java.util.AbstractList$Itr.next(AbstractList.java:420)
	at ch.cyberduck.core.Cache.get(Cache.java:94)
	at ch.cyberduck.ui.cocoa.CDBrowserTableDataSource.childs(CDBrowserTableDataSource.java:79)
	at ch.cyberduck.ui.cocoa.CDBrowserOutlineViewModel.outlineViewNumberOfChildrenOfItem(CDBrowserOutlineViewModel.java:73)
	at com.apple.cocoa.application.NSTableView.reloadData(Native Method)
	at ch.cyberduck.ui.cocoa.CDBrowserController.reloadData(CDBrowserController.java:706)
	at ch.cyberduck.ui.cocoa.CDBrowserTableDataSource$1.cleanup(CDBrowserTableDataSource.java:106)
	at ch.cyberduck.ui.cocoa.CDWindowController$1$1.run(CDWindowController.java:115)
	at ch.cyberduck.ui.cocoa.CDMainApplication.sendEvent(CDMainApplication.java:48)

comment:4 Changed on Oct 6, 2008 at 12:19:38 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.