Cyberduck Mountain Duck CLI

#2516 closed defect (fixed)

When copying a link from an S3 file, it fails to include the bucket.

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 3.0.3
Component: s3 Version: 3.0.2
Severity: major Keywords:
Cc: elan@… Architecture:
Platform:

Description (last modified by dkocher)

  1. Connect to S3
  2. Create a folder named "test"
  3. Upload a file (e.g. "foo.txt")
  4. Right click on the file and select "Copy URL"
  5. The URL will not be ".../test/foo.txt" but rather ".../foo.txt"

Change History (6)

comment:1 Changed on Aug 29, 2008 at 2:05:36 PM by dkocher

  • Description modified (diff)
  • Milestone changed from 3.1 to 3.0.3
  • Status changed from new to assigned

comment:2 Changed on Aug 29, 2008 at 2:09:52 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

The bucket name is ommited in the path but instead added to the domain name. E.g. test.s3.amazonaws.com/foo.txt which should resolve correctly.

comment:3 Changed on Aug 29, 2008 at 7:38:35 PM by leafmuncher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Some more possibly relevant information:

  • I don't have a path in my S3 connection.
  • I use "New Folder..." to make the folder, I called it "Bogus"
  • I then dragged a file named Marriott-bed-4.jpg into the folder.

It's definitely a bug, just not sure what's different between our two setups. Feel free to contact me over email if you need more information. I'm on the CC.

comment:4 Changed on Aug 31, 2008 at 11:37:47 AM by dkocher

I can confirm this now. It happens if you create a bucket using an uppercase character. Because the DNS system is not case sensitive, uppercase buckets are not accessible using a virtual hostname for the bucket name.

comment:5 Changed on Aug 31, 2008 at 11:44:58 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r4171.

comment:6 Changed on Dec 27, 2008 at 5:08:18 PM by dkocher

  • Component changed from amazon-s3 to s3
Note: See TracTickets for help on using tickets.
swiss made software