Cyberduck Mountain Duck CLI

#2550 closed enhancement (wontfix)

sorting order (filename) not equal to Finder

Reported by: achimf@… Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 3.0.2
Severity: normal Keywords:
Cc: achimf@… Architecture:
Platform:

Description

When sorting the list of filenames "alphabetically" Cyberduck returns a different order than the Finder application. Which makes a visual compare of directories (local vs. remote) very difficult. Browsing the web for an explanation it became clear that Finder is sorting "lexicographically" or at least by design differently than for example the MS Windows Browser (and in this case also Cyberduck).

I could not find a way to adjust the sorting order in Finder - it seems as Apple is insisting on the current implementation - as also used in many mainframe operating systems.

However, since Cyberduck is relying on Finder as the browser for the files held locally I would claim the method of sorting should be identical. One way or any other!??

Thanks for your time.

Change History (2)

comment:1 Changed on Sep 10, 2008 at 8:33:19 PM by dkocher

  • Type changed from defect to enhancement

The ordering should be the same as in Finder.app using natural sort order comparison. Can you give the difference you spotted?

comment:2 Changed on Sep 11, 2008 at 6:11:07 PM by dkocher

  • Milestone 3.1 deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software