Cyberduck Mountain Duck CLI

#2553 closed defect (worksforme)

Error with active transfer (PORT) on TSL enabled FTP

Reported by: neothematrix Owned by: dkocher
Priority: normal Milestone:
Component: ftp-tls Version: 3.0.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

I was trying to connect to a TLS enabled FTP site using active transfers, login works, but when I try to download a file, which is where the PORT ... command is issued, I receive this error:

"No available certificate or key corresponds to the ssl cipher suites which are enabled"

I tried with different FTPS, same error, it seems Cyberduck has some problem in creating an SSLServerSocket in order to receive connections back from the FTP.

I can provide a TLS enabled FTP to test the issue.

Change History (2)

comment:1 Changed on Oct 17, 2008 at 9:33:49 PM by dkocher

  • Milestone 3.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the credentials. I cannot reproduce it here, however. Is there a proxy or firewall in between that may be the culprit?

comment:2 Changed on Apr 14, 2009 at 8:30:14 PM by dkocher

A second report in #3113.

Note: See TracTickets for help on using tickets.